Ask Your Question
1

Set up Cockpit for Fedora Server on virtualbox?

asked 2016-03-12 00:31:01 -0500

Bove gravatar image

Hi, I'm setting up a fedora installation in virtual box, but I'm having trouble setting up the cockpit configuration so I can monitor the server from my browser. This is what I ran in Fedora's console:

sudo dnf install cockpit

systemctl status cockpit.service

systemctl enable cockpit.service

systemctl start cockpit.service

firewall-cmd --list-all

firewall-cmd --add-service=cockpit

firewall-cmd --add-service=cockpit --permanent

Tried my_ip_adress:9090 and vm_id_adress:9090 on my browser and it did not work.

It seems that everything is set up properly on the server's side, but I'm not able to access cockpit from my browser and I think it has to do with virtualbox. Maybe I have to set up something in virtualbox's network section?

Thanks for any help :)

edit retag flag offensive close merge delete

Comments

Did you try enabling http & https?

 $ sudo firewall-cmd --permanent --add-service=http
$ sudo firewall-cmd --permanent --add-service=https
$ sudo systemctl reload firewalld

see : http://www.tecmint.com/install-lamp-a...

PamThu gravatar imagePamThu ( 2016-03-17 00:13:13 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-03-13 17:45:12 -0500

paulojmlopes gravatar image

updated 2016-03-13 17:45:39 -0500

Not sure, but you missed one command: firewall-cmd --reload

edit flag offensive delete link more
1

answered 2016-03-13 12:39:39 -0500

fcomida gravatar image

change virtualbox networking to bridged

edit flag offensive delete link more

Comments

+1 cockpit must be on the same realm ;) and setting the network interface of guest on 'bridged' will do that trick, oc

nippur gravatar imagenippur ( 2017-02-08 06:47:35 -0500 )edit

Question Tools

Stats

Asked: 2016-03-12 00:31:01 -0500

Seen: 426 times

Last updated: Mar 13 '16