Ask Your Question

set default entry in grub on fedora 18

asked 2013-02-06 07:52:18 -0500

Rahul Bhadana gravatar image

updated 2013-09-03 17:02:38 -0500

FranciscoD_ gravatar image

i am unable to set windows 8 as the default entry in grub 2 (Fedora 18)

i try following but nothing happen

1 - Setting default entry in

2 -

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2013-02-06 10:42:43 -0500

kynde gravatar image

updated 2013-02-06 10:46:06 -0500

Edit that line in /etc/grub2/grub.cfg :

set default="0"

That 0 means first entry, 1 for second and so forth.

Notice that this does not survive grub2-mkconfig, and also notice that this is not the recommended method, but since you did link to the recommended and didn't get that to work, I feel it's ok to suggest this, because this does work.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2013-02-06 07:52:18 -0500

Seen: 4,212 times

Last updated: Sep 03 '13