Ask Your Question
0

Having a problem setting environment variables in Fedora23

asked 2016-02-26 13:53:34 -0600

nielsk gravatar image

updated 2016-02-26 13:58:02 -0600

I set up Japanese input in Gnome but it doesn't work. The environment variables for QT_IM_MODULE and GTK_IM_MODULE are set wrong. Apparently QT_IM_MODULE gets set to xim, GTK_IM_MODULE to gtk-im-context-simple

But I have set them now in the following file to ibus:

  • ~/.xinitrc
  • ~/.profile
  • ~/.xprofile
  • ~/.gnomerc
  • ~/.xim
  • ~/.xsession
  • ~/.xinputrc

Still something gets sourced after those files. I am trying it with gnome and i3. Both times logging in through gdm. I just tried it with startx and oh wonder they get set and ibus works perfectly. So what gets sourced so late that it overwrites all my local stuff above? And where could I put the settings that gets sourced last when using gdm?

Setting up Japanese input in Fedora feels like I get send back in time 10-15 years and I am a bit desperate… :/

edit retag flag offensive close merge delete

Comments

ibus works when I set the language to Japanese in Gnome Control Center (changes LANG and GDM_LANG). That is a workaround but I'd prefer to use en_US.utf8 for LANG instead of ja_JP.UTF-8

nielsk gravatar imagenielsk ( 2016-02-26 14:30:32 -0600 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2016-02-26 23:30:50 -0600

nielsk gravatar image

In Fedora23 the correct placement for .xinputrc is ~/.config/imsettings/xinputrc There is a script /etc/X11/xinit/xinitrc.d/50-xinput.sh which should move a .xinputrc to ~/.config/imsettings/xinputrc but that fails for some reason in my system. When the above file is missing there is a hardcoded list (incl. the comment that this list should be removed) with languages that set up which language-settings will set up the environment variables for ibus. If your language isn't in that list, it will be set to none essentially.

Dear Fedora-Project this is too much magic going on behind the scenes and complicates system configuration a lot…

edit flag offensive delete link more

Comments

I have a related problem in modifying the environmental variables in Fedora20. This makes the decision to upgrade less likely as it seems to be much more difficult to modify environmental variables in Fedora23. There should be a simple way to configure environmental variables. For example, a simple LC_TIME modification to allow the format Sun 2016-02-28 04:35:15 -07 seems to be almost impossible unless the user is a master system programmer. It should be something simple. For example, the way you would program the date and time format in LibreOffice.

jadesword gravatar imagejadesword ( 2016-02-28 05:35:12 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2016-02-26 13:53:34 -0600

Seen: 602 times

Last updated: Feb 26 '16