Unknown Display - Wrong max resolution for secondary monitor

asked 2016-02-18 21:18:57 -0600

gglasses gravatar image

updated 2016-02-20 12:56:59 -0600

mether gravatar image

Hi guys! I have now a RCA RC32D2 TV and it is 32". The thing is that it should have an aspect ratio of 16:9.

Here's the output of xrandr:

Screen 0: minimum 8 x 8, current 2390 x 768, maximum 32767 x 32767
LVDS1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1366x768      60.02*+
   1280x720      60.00  
   1024x768      60.00  
   1024x576      60.00  
   960x540       60.00  
   800x600       60.32    56.25  
   864x486       60.00  
   640x480       59.94  
   720x405       60.00  
   680x384       60.00  
   640x360       60.00  
DP1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
VGA1 connected 1024x768+1366+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768      60.00* 
   800x600       60.32    56.25  
   848x480       60.00  
   640x480       59.94  
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

As you can see, I'm connection my TV with a VGA cable and has the name VGA1 so I did the following according to xrandr guide to add the resolution 1366x768

cvt 1366 768 60
xrandr --newmode "1368x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync
xrandr --addmode VGA1 1368x768_60.00

And well, it doesn't seem to work or the resolution is still too low because I still don't see the complete screen on my second monitor, for example I'm using Firefox right now but I don't see the complete browser, the right part seems incomplete. I tried adding the following 16:9 resolution which is 1600x900 but without luck, here's what I did:

cvt 1600 900 60
xrandr --newmode "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync
xrandr --addmode VGA1 1600x900_60.00

Then I went to Display > Unknown Display > 1600x900 and clicked on keep changes but didn't work! xrandr tell me I'm using 1368x768 resolution! Any help would be so much appreciated guys!

Also, this is the output for lspci, I did this to know my video card:

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)

Edit: The TV tell me the resolution is 1280x768. :(

edit retag flag offensive close merge delete