Ask Your Question

How to install Fedora dual-boot with Windows 10

asked 2016-02-17 04:23:26 -0600

Toneks gravatar image

updated 2016-02-17 21:58:34 -0600

mether gravatar image

I'm sorry, I've read few similiar topics, but none of them helped me.

What should I do in order to install Fedora 23 into dual-boot next to my Windows 10? I tried it as I used to do it few years ago (when there were no UEFI, Secure boot and all this new "cool" booting stuff) - I moved USB in booting priorities on the first position, booted into live Fedora, installed it, but after reboot it goes straight back into Windows.

Normally I would experiment with it way more, but i don't want to do any damage to my Windows partitions, so I'm being quite careful here and first I would like to know what might be wrong.

edit retag flag offensive close merge delete


You install it from a live image - There is a detailed guide here - . With uefi and secure boot you need to select which OS to boot from your BIOS. In the BIOS there should be a boot menu in the UEFI section. You may or may not need to disable secure boot.

bodhi.zazen gravatar imagebodhi.zazen ( 2016-02-17 06:02:20 -0600 )edit

I disabled secure boot and in BIOS is just only option - Windows Boot Manager.

Toneks gravatar imageToneks ( 2016-02-17 07:09:27 -0600 )edit

Did you boot and install Fedora with UEFI enabled ? Did you make a efi partition ?

bodhi.zazen gravatar imagebodhi.zazen ( 2016-02-17 07:12:58 -0600 )edit

Yes, I booted Fedora with UEFI enabled (checked it) and it created efi partition automaticaly (if it is that 500MB for /boot).

Toneks gravatar imageToneks ( 2016-02-17 07:59:12 -0600 )edit

The most important thing when it comes to BIOS vs. (U)EFI firmware is that all OS' will be installed in the same mode. So, if you have Windows installed in BIOS mode (with secure boot disabled, and it's working fine), don't change any of these settings and install Fedora from a LiveCD. You will have to recreate the partition layout if you have created an efi partition layout).

Fedora installation is taking care of a new bootloader that will include your MS Win OS.

florian gravatar imageflorian ( 2016-02-17 09:56:48 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted

answered 2016-02-19 13:51:31 -0600

suman11121989 gravatar image

I think you should first install windows 10 on first drive and first partition and then install fedora 23 in another partition. Fedora will auto detect the windows and install the boot loader. No any complicated task you have to do, do this and enjoy.

edit flag offensive delete link more


that is what it is supposed to do, but it somehow just keeps pointing to Windows bootloader. That doesn't even bother fedora's bootloader file. (If Windows wasn't installed before Fedora, Fedora grub conf wouldn't include windows bootloader file.) That is why I needed to rename the actual file name so that it solved the problem. I am not sure Toneks has the same issue as mine but copying and renaming really resolved my case.

I think this links is pretty much the same solution as I did.

redpotatojae gravatar imageredpotatojae ( 2016-02-19 14:42:12 -0600 )edit

Thats what I did, actually Windows 10 was there when i bought it. The thing is that Fedora didn't detect Windows 10, it just said Unknown (on partitions with W10).

Toneks gravatar imageToneks ( 2016-02-19 16:49:19 -0600 )edit

answered 2016-02-27 15:28:44 -0600

Toneks gravatar image

updated 2016-02-27 15:28:58 -0600

I finally solved it, I don't doubt that some of the suggested solutions would also work, but I wanted to do it in a "cleaner" way.

I mounted partition and deleted /boot/efi/EFI/fedora (this IMO solved it, after that the next instalation worked), then I released partitions created by my unsuccessful Fedora instalation and simply installed it again. I think that the remaining /EFI/fedora after unsuccessful instalation might have caused problem when installing bootloader.

Thanks to you all :) Without your help i wouldn't have made it.

edit flag offensive delete link more

answered 2016-02-18 21:11:23 -0600

redpotatojae gravatar image

updated 2016-02-19 07:59:40 -0600

I problly can give some help. (I was struggling exact the same thing as your situation.) My bios always looking up /EFT/Microsoft/boot/bootmgfw.efi. no matter what I setup any extra thing. If I manually point to fedora bootloader, my laptop fails to boot up. it simply did not boot or it sometimes force to boot to Windows 10 still. so here is what I did.

I renamed shimx64.efi to bootmgfw.efi (of course I backed up all of windows bootloader files, just in case something fails) anyways, after I installed fedora through EFI, I see the file structor as /boot/efi/EFI/fedora/ 1. copied all of files to /boot/efi/EFI/Microsoft/boot/ 2. rename bootmgfw.efi to bootmgfw_w10.efi under /boot/efi/EFI/Microsoft/boot/ 3. rename shimx64.efi to bootmgfw.efi 4. reboot --> this should boot fedora bootloader * don't forget to disable secure boot (this will failed to boot) after booting to fedora, you need a couple of more things to modify because the windows bootloader filename is changed. on Fedora, open terminal and open a file where grub.cfg is it should be the same place where the files were copied to /boot/efi/EFI/Microsoft/Boot/grub.cfg in the file, you need to replace bootmgfw.efi to bootmgfw_w10.efi (just like the name I changed earlier) that's it. now you should be able to boot Windows again now.

I am not sure this is the case you are having but try it if you cannot boot to fedora from your bios. I think this should work as far as your bios doesn't give you much options to boot something else.

hope this helps!

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2016-02-17 04:23:26 -0600

Seen: 29,680 times

Last updated: Feb 27 '16