Ask Your Question

Fedora 20 yum update problem with repomd.xml -- Error 404 - Not Found

asked 2016-02-15 06:17:04 -0600

joelwatsonfish gravatar image

Hi, I've been using Fedora 20 for a while, but I'm still a newb. I'm trying to install emacs via yum, and I'm having some difficulties. In particular, if I do the following

$ sudo clean all

I get

Loaded plugins: langpacks, refresh-packagekit
Cleaning repos: Dropbox adobe-linux-x86_64 fedora fedora-debuginfo fedy
              : google-chrome home_DarkPlayer_Pipelight oncloud rpmfusion-free
              : rpmfusion-free-updates rpmfusion-nonfree
              : rpmfusion-nonfree-updates updates
Cleaning up everything

and then the problem:

$ sudo yum update


Loaded plugins: langpacks, refresh-packagekit
Dropbox                                                                                                                                                    |  951 B  00:00:00     
adobe-linux-x86_64                                                                                                                                         |  951 B  00:00:00 [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.

 One of the configured repositories failed (Fedora 20 - x86_64),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Disable the repository, so yum won't use it by default. Yum will then
        just ignore the repository until you permanently enable it again or use
        --enablerepo for temporary usage:

            yum-config-manager --disable fedora

     4. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice

            yum-config-manager --save --setopt=fedora.skip_if_unavailable=true

failure: repodata/repomd.xml from fedora: [Errno 256] No more mirrors to try. [Errno 14] HTTP Error 404 - Not Found

I've tried

$ wget

which yields

--2016-02-15 07:02:41--
Resolving (,,, ...
Connecting to (||:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2016-02-15 07:02:41 ERROR 404: Not Found.

Anyway, I'm at a loss for what to do next, so any help would be appreciated.

edit retag flag offensive close merge delete


probnably not what you want to hear, but I think it is going to be faster and more reliable to just do a fresh install of fedora 23 as there are a number of significant changes since Fedora 20

bodhi.zazen gravatar imagebodhi.zazen ( 2016-02-15 08:56:04 -0600 )edit

That would be rather unfortunate. I'm running this on a MacBook Air which I had the IT people at a previous employer set up for me (not in a virtual box, and not dual boot). I'm not confident in my ability to do a fresh install on this machine.

joelwatsonfish gravatar imagejoelwatsonfish ( 2016-02-15 09:17:20 -0600 )edit

Those repos are offline because Fedora 20 is end of life since mid 2015.

I would do a fresh reinstall of Fedora 23 (after backing up) as suggested by @bodhi.zazen.

If you still want to try to uprade, take a look a this wiki article about FedUp.

sudo yum install fedup
sudo fedup --network 23 --product=workstation

...should do the trick. You may need to download an rpm for fedup (whatever version was included in Fedora20) if Fedora repo is not available.

florian gravatar imageflorian ( 2016-02-15 11:21:53 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2016-02-18 03:59:48 -0600

Hi: You need to update your repo configuration (all the fedora* on /etc/yum.repos.d/) to point to so instead of something like


now you have


But, as everybody agrees, the best thing to do is to go for the latest version of Fedora.


edit flag offensive delete link more

Question Tools


Asked: 2016-02-15 06:17:04 -0600

Seen: 3,039 times

Last updated: Feb 18 '16