Ask Your Question
0

Unable to boot EFI Windows 10 from MBR Fedora 23

asked 2016-02-09 15:33:17 -0500

iamcubeman gravatar image

I have 3 Hard drives, Windows 10 on one, and Fedora on the other two (Root and Home). However, due to past implications, I had to install Windows 10 in EFI (not UEFI) mode on a GPT disk. Later I installed Fedora 23 on the other hard disks, and, for simplicity sake, in legacy mode on an MBR disk.

I'd like to have one bootloader so I don't have to go into the boot menu every time. However, this is a tricky situation, since one OS is in EFI Mode, and the other in Legacy. I have Grub configured to boot Fedora, and I have a custom entry to chainload the Windows EFI partition (since it doesn't come up when updating Grub). Here is my 40_custom

When I go to boot Windows from Grub like this, I get

Error: Invalid Signature

How do I fix this?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2016-02-09 23:46:14 -0500

The signature error is related to Secure Boot, a standard for locking a system down to trusted operating systems. The operating system's bootloader is trusted by the UEFI firmware because it is signed with a known and trusted key. On Linux systems, this trust requirement extends to the kernel and kernel modules.

However, this is only a symptom of the problem. You've already loaded the system into legacy mode by the time you try Windows; not only would the trust chain be broken, but you're using legacy grub too, and the EFI build of grub is intended for chainloading other EFI bootloaders.

To avoid this problem, you should remove GRUB from the MBR of that drive and reinstall Fedora with legacy mode disabled.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-02-09 15:33:17 -0500

Seen: 540 times

Last updated: Feb 09 '16