Ask Your Question
1

Dualboot Windows 10/Fedora on separate HDs = no Fedora boot

asked 2016-02-04 19:20:57 -0600

xmetax gravatar image

updated 2016-02-05 20:46:59 -0600

mether gravatar image

Hello,

I had Windows 10 installed first on 1 hard drive. After updating I installed Fedora 23 Cinnamon on my 2nd HD. Both SSDs. Reboot after installation of Fedora and no Grub screen. It simply goes into Windows 10 without giving me a choice. No issue when they shared the same SSD. Not using UEFI. How do I fix this?

Edit: I setup Fedora with a simple EXT4 and Swap partition. No LVM.

Thanks in advance.

edit retag flag offensive close merge delete

Comments

Litte information. Maybe your boot order is not setup correctly. Check where your bootloader grub is installed and choose that drive to be booted first (in BIOS firmware)

Otherwise, show us the output of lsblk and/or fdisk -l.

florian gravatar imageflorian ( 2016-02-04 21:59:12 -0600 )edit

Florian give you the answer. If Windows' HDD is the first in the boot order in BIOS settings it will ignore the second HDD's GRUB, because it find the Windows' MBR, so it just boot.

thewanderer gravatar imagethewanderer ( 2016-02-05 04:22:34 -0600 )edit

I wasn't the one asking. Feel free to post this as an answer!

florian gravatar imageflorian ( 2016-02-05 09:08:57 -0600 )edit

Sorry, I edit the first sentence: Florian has already gave you the answer.

thewanderer gravatar imagethewanderer ( 2016-02-05 11:23:41 -0600 )edit

@thewanderer, sorry, I could have had a bit more imagination to understand what you meant.

florian gravatar imageflorian ( 2016-02-05 11:42:32 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2016-02-05 23:40:36 -0600

xmetax gravatar image

Changing the boot order in BIOS did the trick. TYVM!

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-02-04 19:20:57 -0600

Seen: 682 times

Last updated: Feb 05 '16