Ask Your Question
0

Error while installing Oracle Vbox in Fedora 17

asked 2012-07-12 06:11:23 -0600

Rhnblk gravatar image

updated 2014-09-28 16:14:23 -0600

mether gravatar image

I just replaced my Fedora 16 with 17, Now Im not able to install Vbox. Dependencies error comes out. Please help. The error is this

warning: VirtualBox-4.1-4.1.18_78361_fedora17-1.i686.rpm: Header V4 DSA/SHA1 Signature, key ID 98ab5139: NOKEY
error: Failed dependencies:
    libGL.so.1 is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libQtCore.so.4 is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libQtGui.so.4 is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libQtNetwork.so.4 is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libQtOpenGL.so.4 is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libSDL-1.2.so.0 is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libX11.so.6 is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libXcursor.so.1 is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libXext.so.6 is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libXinerama.so.1 is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libXmu.so.6 is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libXt.so.6 is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libasound.so.2 is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libc.so.6 is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libc.so.6(GLIBC_2.0) is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libc.so.6(GLIBC_2.1) is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libc.so.6(GLIBC_2.1.1) is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libc.so.6(GLIBC_2.1.2) is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libc.so.6(GLIBC_2.1.3) is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libc.so.6(GLIBC_2.15) is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libc.so.6(GLIBC_2.2) is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libc.so.6(GLIBC_2.2.3) is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libc.so.6(GLIBC_2.3) is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libc.so.6(GLIBC_2.3.2) is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libcrypt.so.1 is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libcrypt.so.1(GLIBC_2.0) is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libcrypto.so.10 is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libcurl.so.4 is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libdl.so.2 is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libdl.so.2(GLIBC_2.0) is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libdl.so.2(GLIBC_2.1) is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libgcc_s.so.1 is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libgcc_s.so.1(GCC_3.0) is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libgcc_s.so.1(GLIBC_2.0) is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libm.so.6 is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libm.so.6(GLIBC_2.0) is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libm.so.6(GLIBC_2.1) is needed by VirtualBox-4.1-4.1.18_78361_fedora17-1.i686
    libpng15.so.15 is needed by VirtualBox-4.1-4.1 ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-08-16 12:47:55 -0600

chinosoliard gravatar image

updated 2012-08-16 14:55:47 -0600

hhlp gravatar image

How did you install VirtualBox?

I installed it with this steps:

  1. Download the VirtualBox oficial repository

    $ wget http://download.virtualbox.org/virtualbox/rpm/fedora/virtualbox.repo

  2. After that, move the downloaded .repo file to the repositories folder:

$ sudo mv virtualbox.repo /etc/yum.repos.d/

  1. Then, install the kernel headers, with this command:

$ sudo yum install gcc kernel-headers dkms kernel-devel

  1. Finishing, install VirtualBox...

$ sudo yum install VirtualBox-4.1

I recomend to do a yum update after install everything.

edit flag offensive delete link more

Comments

@davidva try to use english in askfedora (as possible), we don't have language support yet thx...

hhlp gravatar imagehhlp ( 2012-08-17 02:43:21 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2012-07-12 06:11:23 -0600

Seen: 1,566 times

Last updated: Aug 16 '12