Ask Your Question
7

How can I delete a file pressing only "delete" key? (In Gnome 3.6)

asked 2013-01-01 20:08:40 -0600

q2dg gravatar image

updated 2014-09-28 08:44:25 -0600

mether gravatar image

Hello. On earlier versions of Gnome it was fairly trivial to restore the sane default of deleting things when the delete key was pressed, instead of having to press ctrl+delete. Unfortunately, it required using nautilus and the 'can change accels' dconf key. Now that nautilus has been replaced with Files and its edit menu removed, I need to find a new way to change the delete function.

I've also changed the file ~/.gnome2/accels without success

Many thanks

P.D: When I say "delete" I mean "move to trash"

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
6

answered 2013-01-25 07:24:20 -0600

skytux gravatar image

updated 2013-01-25 10:29:56 -0600

hhlp gravatar image

I have posted a solution here:

https://ask.fedoraproject.org/question/3672/solved-enable-delete-key-in-nautilus-36

I didn't see your question before, sorry.

If you want to press only the delete key in Nautilus 3.6 in order to delete files, and not the combination ctrl+delete, then you have to edit the following file in your home directory, for example using vim:

$ vim ~/.config/nautilus/accels

and replace this line (number 5 in my case):

; (gtk_accel_path "<Actions>/DirViewActions/Trash" "<Primary>Delete")

by this one:

(gtk_accel_path "<Actions>/DirViewActions/Trash" "Delete")

Then restart Nautilus and press del key as always to delete any file :)

HTH.

edit flag offensive delete link more

Comments

It works perfectly for me using Nautilus 3.6.3. Please do exactly as I indicate in my post above and restart Nautilus after the changes have been made. Good luck :)

skytux gravatar imageskytux ( 2013-01-27 18:03:14 -0600 )edit
1

@q2dg you don't need to change the topic as solved, you only have to do it, is mark the answer as solved an credit goes to @skytux :) thx.

hhlp gravatar imagehhlp ( 2013-01-28 05:53:34 -0600 )edit

I have edited the specifed line but I don't know how I can save the edition.

tareq gravatar imagetareq ( 2013-05-14 13:02:16 -0600 )edit

@tareq: it depends on the editor you are using

skytux gravatar imageskytux ( 2013-05-14 13:15:54 -0600 )edit

using vim: esc + :wq + enter

skytux gravatar imageskytux ( 2013-05-14 13:18:44 -0600 )edit
3

answered 2013-01-02 18:41:32 -0600

LonelySpooky gravatar image

Run dconf-editor, and open: org -> gnome -> desktop -> interface Enable "can-change-accels". Open nautilus, select any file/directory, then click "Edit" from menubar, and hover on "Move to Trash" menuitem. While hovering, click on your delete key. The accel should change from "cntrl+del" to "del". Make sure you have selected a file, else the "Move to Trash" menuitem will be greyed out. I suggest you disable "can-change-accels" afterwards, to prevent accidental accel changes.

source: https://bbs.archlinux.org/viewtopic.php?id=116609

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-01-01 20:08:40 -0600

Seen: 13,655 times

Last updated: Jun 20 '13