Ask Your Question
1

How to put Windows 7 Guest on F23 QEMU/KVM in Sleep/Hibernate?

asked 2016-01-11 14:23:23 -0600

ceres2009 gravatar image

updated 2016-02-01 21:57:16 -0600

mether gravatar image

Hi, this is kind of a followup question to the scenario in Ask I did switch to F23 as a host and Win7 as a QEMU/KVM guest and so far it goes quite well.

One of the remaining issues is, that the W7 Guest cannot be put into Sleep S3 or Hibernate S4 mode at all. I tried Passmark Sleeper to see which modes are supported and it tells: none. The only Powermanagement Feature supported is shutdown on power button press.

I'm using the Spice Windows Drivers for graphics/mouse support.

From VMWare i was used to "pause virtual machine", that is hibernating the guest vm from outside, which i used a lot.

Is there any feature like the one in vmware in QEMU? Has anybody managed to get such a vm to support S3/S4 from inside the guest?

Best, C.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-03-02 14:38:04 -0600

ceres2009 gravatar image

to answer the question myself: The problem i had lied in either in the default selected chipset 440FX or in the conversion from a vmdk to qcow I set up a second vm and used Q35 as a chipset this time and made a fresh install of W7. Now at least hibernate works, but suspend results in a bluescreen. And the side effect the vm also takes only one third of the CPU Time, when it idles!

edit flag offensive delete link more

Comments

You're on the right track - the default CPU presented to the guest is a virtual one; this is so guests can be easily migrated. You can set the CPU arch via virsh edit, however; using the native processor type - and virt-manager does have a 'pause' button.

randomuser gravatar imagerandomuser ( 2016-03-02 19:49:51 -0600 )edit

Found the reference I was looking for - https://libvirt.org/formatdomain.html... . You should try <cpu mode='host-model'> or <cpu mode='host-passthrough'> to test the theory!

randomuser gravatar imagerandomuser ( 2016-03-02 19:54:35 -0600 )edit

thanks, i will try that and see if it works. In my experience the pause button already works fine, but afterwards the VM (at lease Windows) or better the GUI of the VM is running extremly fast. Looks like an issue with the time difference and how windows keeps trying to catch the "lost time" while pausing. => in that case it's not usable anymore. However i made some changes to windows timer (as suggested in antoher thread here, to ensure the right timezone is selected whilst cold-booting both - host and guest.

ceres2009 gravatar imageceres2009 ( 2016-03-09 10:08:21 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2016-01-11 14:23:23 -0600

Seen: 2,073 times

Last updated: Mar 02 '16