Ask Your Question

Couldn't resolve host name for

asked 2016-01-04 12:39:52 -0600

shimon001 gravatar image

updated 2016-01-24 23:06:38 -0600

mether gravatar image

Hi all, I have experienced ollowing problem during my Fedora 23 update.

I have chosen Restart & Update in the shutdown menu. After system restart the notification bar displayed a message about update failure, with following error message (during Oracle Virtualbox update):

We’re sorry: the update failed to install. Please wait for another update and try again. If the problem persists, contact your software provider.

Detailed errors from the package manager follow:

Curl error (6): Couldn't resolve host name for [Could not resolve host:]

I have tried to add Oracle GPG key following this guide:

wget -q


sudo rpm --import oracle_vbox.asc

Any help is appriciated.


nslookup result:

[shimon@localhost ~]$ nslookup

Non-authoritative answer:
edit retag flag offensive close merge delete

5 Answers

Sort by » oldest newest most voted

answered 2016-01-04 13:01:36 -0600

sideburns gravatar image

The error message you're reporting says that it's unable to turn the machine name into an IP address so that it can connect to it and download the file. Please edit your question to include the results of this command:


so that we can find out if you're having DNS issues. My computer can resolve the address and connect (although it doesn't respond to pings) so the issue's probably at your end.

And while I'm thinking about it, if you know what your DNS servers are, please include their IP addresses in your edit.

edit flag offensive delete link more


Thanks for your reply. I have updated my post with nslookup result.

shimon001 gravatar imageshimon001 ( 2016-01-04 13:17:39 -0600 )edit

So, your machine can resolve into the correct IP ( Maybe the problem was something intermittent with your provider or on Oracle's system. Have you tried wget or wget in the meantime?

florian gravatar imageflorian ( 2016-01-04 13:55:23 -0600 )edit

I have tried wget with both http/https, and both work OK. Could it be that somehow the name cannot be resolved to IP during update process (computer restart)? Can be VirtualBox update triggered alone, so that it doesn't block rest of updates?

shimon001 gravatar imageshimon001 ( 2016-01-05 00:35:00 -0600 )edit

If that's true, whatever was causing the DNS issue has probably cleared up. Try the update again and see how it works.

sideburns gravatar imagesideburns ( 2016-01-05 01:12:50 -0600 )edit

@shimon001: You mean, you want to perform a dnf upgrade even though the connection to one specific repo (ie virtualbox) fails? In that case you have to temporarily disable that repo. (dnf --disablerepo virtualbox upgrade). There is no --skip-broken option known from yum.

florian gravatar imageflorian ( 2016-01-05 09:21:00 -0600 )edit

answered 2016-01-05 01:35:11 -0600

shimon001 gravatar image

I have ran the update again as root from command line using dnf update, according to the log everything updated successfully (even Virtualbox). Maybe Virtualbox cannot be updated during system restart (maybe the network connection is down and the .asc file cannot be downloaded.

edit flag offensive delete link more

answered 2016-02-25 12:55:40 -0600

Aykut gravatar image

I was having the same problem and dnf update solved my problem.

edit flag offensive delete link more

answered 2016-06-05 01:54:28 -0600

MaroM gravatar image

Again dnf update fixed this error.

edit flag offensive delete link more

answered 2016-05-15 19:49:36 -0600

Zivci gravatar image

Same here, dnf update solved it, Fedora 23.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2016-01-04 12:39:52 -0600

Seen: 2,715 times

Last updated: Jan 05 '16