Ask Your Question
1

Error: Protected multilib versions while yum update

asked 2012-07-20 12:44:03 -0600

wis775 gravatar image

After a frozen yum update (I had to restart the PC after waiting for one hour), I can't update my system anymore.

While executing

sudo yum update

I got the following error

Error: Protected multilib versions: libtiff-3.9.6-1.fc17.i686 != libtiff-3.9.5-3.fc17.x86_64
Error: Protected multilib versions: 1:qt-4.8.2-4.fc17.i686 != 1:qt-4.8.2-2.fc17.x86_64
Error: Protected multilib versions: 1:qt-x11-4.8.2-4.fc17.i686 != 1:qt-x11-4.8.2-2.fc17.x86_64

How can I fix this?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
3

answered 2012-07-20 13:18:27 -0600

jmt gravatar image

Due to the interrupted yum session you probably have duplicate versions of some packages. You can recover from this problem by using the command

package-cleanup --cleandupes

The command comes with the yum-utils package.

edit flag offensive delete link more

Comments

This command works fine!

LSLOVECN gravatar imageLSLOVECN ( 2012-11-20 14:56:23 -0600 )edit

Hi all, I am trying to get Skype installed on Fedora 18 64 bits OS. I am following the instructions on the next link: http://www.if-not-true-then-false.com/2012/install-skype-on-fedora-centos-red-hat-rhel-scientific-linux-sl/ I am getting the following error(similar to the first one poster, but it has nothing to do with duplicate versions) while trying to install the first dependencies: Protected multilib versions: freetype-2.4.10-4.fc18.i686 != freetype-2.4.10-3.fc18.x8664 Error: Protected multilib versions: 1:qt-4.8.4-17.fc18.i686 != 1:qt-4.8.4-14.fc18.x8664 Thanks in advance!

rodionrom gravatar imagerodionrom ( 2013-06-02 09:20:09 -0600 )edit

This command completely broke my system. No desktop environment, not even LAN connection while booting into command line.

Bucic gravatar imageBucic ( 2014-05-01 13:12:02 -0600 )edit

It would be a good idea to do a yum update as well when encountering this issue.

randomuser gravatar imagerandomuser ( 2014-07-15 00:18:16 -0600 )edit

@rodionromrpm -q freetype (you will probably get two versions of freetype installed) keep the latest version and remove the previous version(s) by using yum remove freetype-<previous_version> Do the same for all the packages with protected multilib versions error. I have the same issue and by performing the above-mentioned steps, I was able to get rid of the problem. :)

HTH!

makpro gravatar imagemakpro ( 2014-08-27 16:08:45 -0600 )edit
0

answered 2013-07-28 10:21:54 -0600

yum install xx.x86_64, then yum install xx.i686

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-07-20 12:44:03 -0600

Seen: 32,255 times

Last updated: Jul 28 '13