Ask Your Question
0

Aspire S3 Fan and brightness doesn't work Fedora 16

asked 2012-04-28 00:56:58 -0600

danitx gravatar image

updated 2015-03-28 10:30:53 -0600

There is a way to get fix this??

I'm deciding to leave fedora I can't find how fix this, I can live with brightness high, but with the fan issue not.

Linux 3.3.2-6

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-04-28 11:16:54 -0600

Brallan gravatar image

updated 2012-04-28 11:24:24 -0600

In the case of the Fan problem, you could try to modify the /etc/default/grub file. Add at the end of the line titled GRUB_CMDLINE_LINUX the instruction acpi_osi=Linux. This is an example of my grub file:

GRUB_TIMEOUT=5

GRUB_DISTRIBUTOR="Fedora"

GRUB_DEFAULT=saved

GRUBCMDLINELINUX="rd.md=0 rd.lvm=0 rd.dm=0 quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 KEYTABLE=es LANG=en_US.UTF-8 acpi_osi=Linux"

GRUB_GFXMODE=1366x768x16

GRUBGFXPAYLOADLINUX=keep

GRUB_BACKGROUND=/usr/share/backgrounds/verne/default/wide/verne.png

Finally, update grub (as superuser):

grub2-mkconfig -o /boot/grub2/grub.cfg

Reboot!

edit flag offensive delete link more

Comments

@Brallan Aguilar this configuration of grub can reduce the fan sound but the problem is different here fan is nt working,i believe its hardware issue

Akshay gravatar imageAkshay ( 2012-04-28 13:18:55 -0600 )edit
0

answered 2012-04-28 08:37:10 -0600

Akshay gravatar image
edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-04-28 00:56:58 -0600

Seen: 411 times

Last updated: Apr 28 '12