Ask Your Question
0

Why won't VirtualBox install on F23?

asked 2015-12-21 06:33:27 -0600

jernieh gravatar image

updated 2015-12-22 10:34:24 -0600

I had VirtualBox running perfectly on F20 but since I've updated to F23 I've found it impossible to install VB. I've seen several pages supposedly telling me how to do it, including all the extra programs that are needed for it to work but despite following the advice on all of them I end up with "No package VirtualBox to install". I've even downloaded it from the VB website and attempted to load it manually but haven't managed to do so. I don't recall having any problem at all on F20. Any suggestions anyone?

edit retag flag offensive close merge delete

Comments

I have it installed on Fedora 23, what errors are you seeing?

Did you install from the rpmfusion.org repository?

cobra gravatar imagecobra ( 2015-12-21 08:49:47 -0600 )edit

check other questions like : https://ask.fedoraproject.org/en/ques...

sergiomb gravatar imagesergiomb ( 2015-12-21 09:44:18 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-12-22 11:01:30 -0600

Hi:

Enalbe the RPMFusion repos and then install it via dnf (all the required dependencies will be also installed in the process, VirtualBox-kmodsrc, akmod-VirtualBox, etc.)

[casep@X201t ~]$ sudo dnf info VirtualBox
Last metadata expiration check performed 1:01:48 ago on Tue Dec 22 15:56:44 2015.
Available Packages
Name        : VirtualBox
Arch        : x86_64
Epoch       : 0
Version     : 5.0.10
Release     : 1.fc23
Size        : 26 M
Repo        : rpmfusion-free-updates-testing
Summary     : A general-purpose full virtualizer for PC hardware
URL         : http://www.virtualbox.org/wiki/VirtualBox
License     : GPLv2 or (GPLv2 and CDDL)
Description : A general-purpose full virtualizer and emulator for 32-bit and
            : 64-bit x86 based PC-compatible machines

Kind regards

edit flag offensive delete link more

Comments

Thanks for that. I installed the repos and managed - eventually - to get VirtualBox to install but it still won't work. I get an error 3 VERR_VM_DRIVER_NOT-iNSTALLED (-1908). I've tried various ways to fix this, taken from various websites, including installing DKMS and several commands to /etc/init files, none of which worked because they all said No such file or directory. I'm no expert on command-line, I just copy and paste what I find on websites and hope for the best.

Even allowing for my lack of knowledge I installed it easily on F20 and it worked. What am I doing wrong?

jernieh gravatar imagejernieh ( 2015-12-23 04:06:09 -0600 )edit

As pointed out above, this is already answered here: https://ask.fedoraproject.org/en/ques...

The accepted answer on there was to follow the guide here: http://www.if-not-true-then-false.com...

I think you need to pick up from about halfway through step 5.

Please remember the contributors here are volunteers - you can help them help you by reading the stuff they point you at to resolve your issue.

cobra gravatar imagecobra ( 2015-12-23 04:20:25 -0600 )edit

Thanks again, and I'm sorry I've caused so much hassle. I really struggle with command-line and I had already been through the suggested website and found it wouldn't work, largely it would seem because it didn't suggest the correct repo. One of the further steps caused me a few problems by not working as it should but I eventually managed to get around that and, fingers crossed, it seems now to be working. Why is it so much harder than it was in F20? Even an idiot like me managed to load it previously. I almost got to the point where I was going to reload F20!

jernieh gravatar imagejernieh ( 2015-12-24 04:29:33 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2015-12-21 06:33:27 -0600

Seen: 408 times

Last updated: Dec 24 '15