Ask Your Question
0

I enabled SELinux on Fedora 23 and it did not boot

asked 2015-12-12 09:55:22 -0500

Andrei Cristian Petcu gravatar image

updated 2015-12-12 17:39:25 -0500

Hi! I enabled SELinux on Fedora 23 Workstation (Gnome) and it did not boot. $cat /etc/selinux/config

SELINUX=permissive

SELINUXTYPE=targeted

Here is my log https://paste.fedoraproject.org/300124/

What am I doing wrong? Thank you!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-12-12 12:46:58 -0500

aeperezt gravatar image

Looks like your issue is you have ELINUX=permissive it should be SELINUX=permissive, now Fedora 23 Workstation already have enabled SELinux with the SELINUX=enforcing in the config file.

Please fix that and see how it goes.

edit flag offensive delete link more

Comments

I wrote SELINUX in the config file. I wrote ELINUX in the question by mistake. O it's not that. Thank you for looking into my issue!

Andrei Cristian Petcu gravatar imageAndrei Cristian Petcu ( 2015-12-12 17:40:07 -0500 )edit

Check the log file, it picks up the setting "SELinux: Starting in permissive mode"

Andrei Cristian Petcu gravatar imageAndrei Cristian Petcu ( 2015-12-12 17:40:45 -0500 )edit

I used Fedy to disable it until I get used to how Fedora works, then I planned to start to enable SELinux in mermissive then to enforcing.

Andrei Cristian Petcu gravatar imageAndrei Cristian Petcu ( 2015-12-12 17:45:51 -0500 )edit

Apparently I had to wait some more time until SELinux relables all my files in my filesystem. It does this when it boots the first time from no-SELinux to SELinux.

Andrei Cristian Petcu gravatar imageAndrei Cristian Petcu ( 2015-12-16 11:22:04 -0500 )edit

That is correct.

aeperezt gravatar imageaeperezt ( 2015-12-17 09:38:19 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-12-12 09:54:05 -0500

Seen: 109 times

Last updated: Dec 12 '15