Ask Your Question
0

Removed libunwind and gnome doesnt work anymore!

asked 2015-12-05 23:32:14 -0500

Thoughtshift gravatar image

updated 2015-12-06 23:10:53 -0500

mether gravatar image

So, I'm new to Linux but pretty decent with computers, and what I'm trying to do is get graphics drivers all set up so I can play Blizzard games on my fedora 23 release. Was working through it, learning about linux the whole time, but this one took me too far. Intel gpu tools requires libunwind (among other things grimace), so just like with everything else I downloaded the package and installed it. Found out I had not installed the exact right version when I kept getting fatal errors in the make command for the gpu tools. So, when I removed the libunwind a day later, gnome crashed and I had to restart. Upon rebooting, I get a command line. I just managed to find out how to login. Please help, my school work is all on this computer and I've barely had fedora for two weeks. I'm clueless and no Internet search has turned up anything remotely related.

edit retag flag offensive close merge delete

Comments

How did you install libunwind? Using dnf? You can always do a sudo dnf history and then undo transactions by running sudo dnf history undo <n> while <n> is the ID in the first column of the previous command. All in all, I guess we need more information about what you did and how you did it and what's the problem now...

florian gravatar imageflorian ( 2015-12-06 21:48:35 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-12-07 19:28:48 -0500

Thoughtshift gravatar image

So found commands to reinstall the correct libunwind and then had to reinstall xorg and a couple other packages. Learned a lot about the terminal, commands, and the fedora package manager. Good times.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-12-05 23:32:14 -0500

Seen: 66 times

Last updated: Dec 05 '15