Ask Your Question

I don't want these applets running in my session

asked 2012-01-26 07:15:04 -0600

viajeramental gravatar image

updated 2014-09-29 23:21:28 -0600

mether gravatar image

Hello all!

 Everytime I start a new session appears two undesired applets: Printer applet and Kmix.  I don't want them starting with the session.  How can I get rid off them?  I don't want to delete them, just that they don't start with the session.

I use KDE 4.7 in Fedora 16.

Sorry for my english. Thanks in advance!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2012-01-26 11:22:30 -0600

ZenDark gravatar image

updated 2012-01-28 12:43:36 -0600

Hide KMix Applet

Create the file .config/autostart/kmix_autostart.desktop

[Desktop Entry]

Hide Printer Applet

Create the file ~/.config/autostart/printer-applet.desktop

[Desktop Entry]

I learned a new form to hide an autostart program :P thanks for your question!!!

For any program autostarted in /usr/share/autostart create a file with the same name in your ~/.config/autostart with that content. It will start hidden.

Disable autostart of KMix & Printer Applet

Delete the autostart files as root (backup them first if needed)


Maybe, if you update the kde desktop they will be created again. Create a empty file in its place.

Remove completely KMix

yum remove kdemultimedia-kmix kdeutils-printer-applet

In my system I can remove the two package without having to remove anyother.

edit flag offensive delete link more

answered 2012-01-28 06:30:24 -0600

viajeramental gravatar image

No. I don't want them hidden, I wan't them disabled. I don't want them running in my session. I don't have any printer and Kmix mistakes my sound, I use PNmixer to control volume. So, I don't want them just hidden, I don't want them at all

Thanks in advance!

edit flag offensive delete link more

Question Tools


Asked: 2012-01-26 07:15:04 -0600

Seen: 987 times

Last updated: Jan 28 '12