Ask Your Question
1

How do I stop applications hiding their titlebar when maximized?

asked 2013-02-12 13:02:10 -0600

ryanlerch gravatar image

updated 2014-09-28 12:24:21 -0600

mether gravatar image

When I maximize particular GNOME applications in Fedora 18, such as Files (Nautilus) and Documents (gnome-documents), the titlebar disappears.

Is there anyway to force this to stop the titlebar from being hidden on maximized windows?

image description

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-02-12 13:14:07 -0600

ryanlerch gravatar image

updated 2013-02-12 15:16:48 -0600

A lot of the newer GNOME applications in Fedora have the new GNOME behaviour of hiding the titlebar when a window is maximized. Further details on this new GNOME behaviour can be found in the draft version of the GNOME3 HIG (Human Interface Guidelines)

Doing this does save some vertical pixel space on smaller screens, however, some users may want to always show the titlebar when maximized. Users may do this so they always have the window title displayed, or the Close / Minimize buttons in the top right always visible.

How do i force the titlebar to always show?

Luckily, there is a GNOME Extension To Force GNOME to always show the titlebar when maximized for all applications:

https://extensions.gnome.org/extension/515/ignorerequesthide_titlebar/

Note: You will most probably need to restart gnome-shell after enabling this extension for it to work properly.

This extension can be enabled from the GNOME extensions library page, and is compatible with Fedora 18 (GNOME 3.6). When applied all your maximized windows will show like this:

image description

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-02-12 13:02:10 -0600

Seen: 4,003 times

Last updated: Feb 12 '13