Ask Your Question

How to stop dnf from automatically downloading updates?

asked 2015-11-26 06:22:51 -0500

salmankhan gravatar image

updated 2015-11-27 08:36:10 -0500

mether gravatar image

I am a Fedora 22 user (newbie). Whenever I use dnf for installing packages, Fedora updates are automatically downloaded first and only then my local rpm package is installed. I want to just install only the rpm package which i specified with the 'dnf install' command, but not the automatic updates.So please tell me how can I stop this automatic update in dnf?

edit retag flag offensive close merge delete


Can you share the exact command you are using, and the output? The behavior I think you are describing,upgrade_requirements_on_install, doesn't happen with dnf.

randomuser gravatar imagerandomuser ( 2015-11-26 11:05:23 -0500 )edit

I think the problem is solved now. I was using 'dnf install <rpm-package>' and the output was downloading fedora22_x86_64-updates

salmankhan gravatar imagesalmankhan ( 2015-11-26 11:22:44 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted

answered 2015-11-26 08:32:01 -0500

anishjp gravatar image

I think you are referring to dnf-makecache.timer, if that is the case you can disable it by

systemctl disable dnf-makecache.timer

To manually check & update

dnf check-update

dnf upgrade
edit flag offensive delete link more


Thank you for your answer. After seeing its man page, i came to know that it is resource aware and won't download updates when running on battery power. By running this command, will it also disable my local dnf cache which i enabled by adding 'makecahe=true' to dnf.conf file?

salmankhan gravatar imagesalmankhan ( 2015-11-26 10:06:49 -0500 )edit

answered 2018-02-03 14:16:39 -0500

Stop update of fedora 27

edit flag offensive delete link more

answered 2018-02-03 14:15:54 -0500

What is gnome

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2015-11-26 06:22:51 -0500

Seen: 3,558 times

Last updated: Nov 26 '15