Ask Your Question
0

Failed to start mongod

asked 2015-11-13 21:42:22 -0600

Brallan gravatar image

Recently I installed MongoDB from Fedora official repositories. When execute:

$ sudo systemctl start mongod
[sudo] password for brallan: 
Job for mongod.service failed. See "systemctl status mongod.service" and "journalctl -xe" for details.

$ systemctl status mongod.service
● mongod.service - High-performance, schema-free document-oriented database
   Loaded: loaded (/usr/lib/systemd/system/mongod.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since vie 2015-11-13 21:29:28 CST; 10s ago
  Process: 5835 ExecStart=/usr/bin/mongod $OPTIONS run (code=exited, status=100)

nov 13 21:29:28 hikari systemd[1]: Starting High-performance, schema-free document-oriented database...
nov 13 21:29:28 hikari mongod[5835]: about to fork child process, waiting until server is ready for connections.
nov 13 21:29:28 hikari mongod[5835]: forked process: 5841
nov 13 21:29:28 hikari mongod[5835]: ERROR: child process failed, exited with error number 100
nov 13 21:29:28 hikari systemd[1]: mongod.service: control process exited, code=exited status=100
nov 13 21:29:28 hikari systemd[1]: Failed to start High-performance, schema-free document-oriented database.
nov 13 21:29:28 hikari systemd[1]: Unit mongod.service entered failed state.
nov 13 21:29:28 hikari systemd[1]: mongod.service failed.

How can I start properly MongoDB?

Some technical aspects:

  • Package mongodb-2.6.11
  • Package mongodb-server-2.6.11
  • 64 bits system
edit retag flag offensive close merge delete

Comments

i have installed mongodb from the fedora repositories

sudo dnf install mongodb

but failed to start too.

exception: connect failed
christianbueno gravatar imagechristianbueno ( 2017-08-17 21:15:01 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2017-08-17 21:34:52 -0600

christianbueno gravatar image

updated 2017-08-17 21:36:06 -0600

FEDORA 26
Installation of mongodb from the fedora repositories.

sudo dnf install mongodb mongodb-server

If you run the command mongo you will get the following problem


 harvey  ~  mongo
MongoDB shell version v3.4.3
connecting to: mongodb://127.0.0.1:27017
2017-08-17T21:19:38.068-0500 W NETWORK  [thread1] Failed to connect to 127.0.0.1:27017, in(checking socket for error after poll), reason: Connection refused
2017-08-17T21:19:38.069-0500 E QUERY    [thread1] Error: couldn't connect to server 127.0.0.1:27017, connection attempt failed :
connect@src/mongo/shell/mongo.js:237:13
@(connect):1:6
exception: connect failed
You could check the status and verify that is inactive(dead)

 harvey  ~  sudo systemctl status mongod.service 
[sudo] password for harvey: 
● mongod.service - High-performance, schema-free document-oriented database
   Loaded: loaded (/usr/lib/systemd/system/mongod.service; disabled; vendor preset: disabled)
   Active: inactive (dead)
You must activate (run) the services.
sudo systemctl start mongod.service
edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-11-13 21:42:22 -0600

Seen: 1,449 times

Last updated: Aug 17 '17