Ask Your Question
1

After update to gtk2 2.24.8-2 meta and alt keys no longer works

asked 2011-12-07 02:23:26 -0600

lzap gravatar image

updated 2011-12-15 13:45:59 -0600

Hello,

After update in F16 ALT-ENTER no longer works in Terminator

I updated yesterday and Terminator no longer accepts ALT-ENTER, key I use very often in Midnight Commander.

This is my update list: http://pastebin.com/CrmhAqfv

From the list of dependencies:

$ rpm -qR terminator
/bin/sh  
/bin/sh  
/usr/bin/python  
GConf2  
desktop-file-utils  
gnome-python2-bonobo  
gnome-python2-gconf  
gtk2  
python(abi) = 2.7
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
vte  
rpmlib(PayloadIsXz) <= 5.2-1

It looks like gtk2 broke it.

Quick look shows nor mc or terminator has been updated. Any tips?

Update: Fix of the vte3 package has been delivered to the Fedora Updates stable repos.

edit retag flag offensive close merge delete

Comments

lzap gravatar imagelzap ( 2011-12-07 02:40:05 -0600 )edit

Okay seems like vte issue: https://bugzilla.gnome.org/show_bug.c...

lzap gravatar imagelzap ( 2011-12-07 02:49:10 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2011-12-07 03:00:05 -0600

lzap gravatar image

updated 2011-12-07 03:09:42 -0600

It's a bug, reported: https://bugzilla.redhat.com/show_bug.cgi?id=760875

Workaround for Fedora 16:

wget http://kojipkgs.fedoraproject.org/packages/gtk2/2.24.7/3.fc16/x86_64/gtk2-2.24.7-3.fc16.x86_64.rpm
wget http://kojipkgs.fedoraproject.org/packages/gtk2/2.24.7/3.fc16/x86_64/gtk2-devel-2.24.7-3.fc16.x86_64.rpm
sudo rpm -Uvh --force gtk2*rpm
edit flag offensive delete link more
1

answered 2011-12-14 14:36:35 -0600

alexlan gravatar image

updated 2011-12-14 14:47:52 -0600

For gtk3-based apps (such as gnome-terminal) in Fedora 16: the pending update for vte3 in updates-testing fixes this: https://admin.fedoraproject.org/updates/FEDORA-2011-17004/vte3-0.30.1-3.fc16

to fix simply run (as root):

yum --enablerepo=updates-testing install vte3

Note that this doesn't necessarily fix the gtk2-based apps like terminator

edit flag offensive delete link more

Comments

@ryran: gnome terminal does not use vte.

lzap gravatar imagelzap ( 2011-12-15 13:45:18 -0600 )edit
1

answered 2011-12-07 09:47:29 -0600

ryran gravatar image

updated 2011-12-14 15:02:17 -0600

Awesome @Izap! Thanks for tracking this down. After reading the posting @ https://bugzilla.gnome.org/show_bug.cgi?id=663779, I think installing a patched rpm of vte is a much better work-around for F16: http://thm.fedorapeople.org/vte/


EDIT: Looks like there's now an updated vte in the testing repo:

yum --enablerepo=updates-testing update vte

I've updated to it and all still seems to be well with my terminator and guake.

edit flag offensive delete link more

Comments

Your link is invalid - should be https://bugzilla.gnome.org/show_bug.cgi?id=663779

lzap gravatar imagelzap ( 2011-12-07 14:37:39 -0600 )edit

Question Tools

3 followers

Stats

Asked: 2011-12-07 02:23:26 -0600

Seen: 482 times

Last updated: Dec 15 '11