Ask Your Question
0

What modifications do I make to my xorg.conf to switch from kmod-catalyst to mesa-gl or vga?

asked 2011-11-28 06:00:43 -0500

Collaborando gravatar image

updated 2011-11-28 19:13:06 -0500

FranciscoD_ gravatar image

How can I configure correctly xorg.conf to switch from kmod-catylst (proprietary) to mesa-gl or vga (driver without 3d)?

Thanks.

edit retag flag offensive close merge delete

Comments

Are you talking about switching drivers for your same ATI card with Xorg ?

SoumyaC gravatar imageSoumyaC ( 2011-11-28 08:00:05 -0500 )edit

I guess you can follow below comments from @bodhi.zazen on your answer. Rather than changing it, its better you move the xorg.conf, as open source driver will not use your xorg.conf.

SoumyaC gravatar imageSoumyaC ( 2011-11-29 06:05:58 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2011-11-28 10:09:51 -0500

ZenDark gravatar image

Just remove kmod-catalyst:

sudo yum remove kmod-catalyst

Xorg uses auto-configure to detect the most suitable driver for your graphic card. If no binary driver is found for your ATI, it should use the free driver (if supported) or fallback to svga/vga

edit flag offensive delete link more
0

answered 2011-11-28 10:09:16 -0500

updated 2011-11-28 10:09:35 -0500

Was your card working before installing the catalyst driver ?

If so, you can simply move your current xorg.conf

su -c "mv /etc/X11/xorg.conf /etc/X11/xorg.conf.ati"

Or you can also remove the catalyst driver.

edit flag offensive delete link more
0

answered 2011-11-28 13:36:43 -0500

Collaborando gravatar image

updated 2011-11-28 13:37:30 -0500

My ati car radeon 5400 work with binary driver (kmod-catalyst) but sometimes I want to switch from kmod-catalyst (binary) to opensource and not 3d enable driver. How can I configure xorg.conf properly?

edit flag offensive delete link more

Comments

1

The catalyst driver configured a xorg.conf for you. To disable the catalyst driver, move it as in my first answer. To enable it move it back. The open source driver does not use a xorg.conf. You will need to restart X.

bodhi.zazen gravatar imagebodhi.zazen ( 2011-11-28 13:46:26 -0500 )edit

The catalyst driver configured a xorg.conf for you.

bodhi.zazen gravatar imagebodhi.zazen ( 2011-11-28 13:46:26 -0500 )edit

Question Tools

Stats

Asked: 2011-11-28 06:00:43 -0500

Seen: 1,218 times

Last updated: Nov 28 '11