Fedora22 nvidia-xconfig fail

asked 2015-10-31 13:40:04 -0600

updated 2015-11-02 18:32:33 -0600

Runing nvidia-xconfig creates a file /etc/X11/xorg.conf with the pertinent config options. Up until now, this has been a standard procedure for me, on all of my systems. However, now on a Desktop running Fedora22 64bit with an nvidia GTX470 GPU, this results in a continuous failure with GDM.

Xlib: extension "XEVIE" missing on display

Removing the xorg.conf file entirely resolves this problem.

Additionally, attempting to add the Coolbits option fails in the /etc/X11/xorg.conf.d/99-nvidia.conf file. This file was created automatically by the system; I assume during the kmod-nvidia installation procedure.

Ultimately, my question is: How do I set the Coolbits option so that I can control the GPU fan? At the moment, I'm forced to reboot into Ubuntu to take advantage of this feature. It would be nice to resolve the entire issue related to the nvidia X configuration; however, the short-term solution for the "Coolbits" option is priority for me at the moment.

cat /etc/X11/xorg.conf.d/99-nvidia.conf 
#This file is provided by xorg-x11-drv-nvidia
#Do not edit

Section "Files"
        ModulePath   "/usr/lib64/nvidia/xorg"
        ModulePath   "/usr/lib64/xorg/modules"
EndSection

The Xorg.0.log file indicates that it's using the /usr/share/X11/xorg.conf.d/ configuration directory. The pertinent file there shows little configuration options:

nl /usr/share/X11/xorg.conf.d/nvidia.conf 
     1  #This file is provided by xorg-x11-drv-nvidia
     2  #Do not edit

     3  Section "OutputClass"
     4          Identifier "nvidia"
     5          MatchDriver "nvidia-drm"
     6          Driver "nvidia"
     7  EndSection

Interesting warning output during nvidia-xconfig execution about missing xorg-server.pc file. IIRC, these are usually provided by ..-devel packages.

# nvidia-xconfig 

WARNING: Unable to locate/open X configuration file.

Package xorg-server was not found in the pkg-config search path.
Perhaps you should add the directory containing `xorg-server.pc'
to the PKG_CONFIG_PATH environment variable
No package 'xorg-server' found
New X configuration file written to '/etc/X11/xorg.conf'

Update

This appears to be an issue with GNOME; if I login to another DesktopEnvironment, i.e. awesome-wm, I'm able to log in successfully and the "Coolbits" option works as expected.

According to the FC22 Common Bugs, this might be related to an issue with Wayland. I'll attempt to make the recommended changes to /etc/gdm/custom.conf when I get a chance and update this Q with an Answer if it works.

edit retag flag offensive close merge delete