Ask Your Question
1

Attempting to bring up wifi connection with nmcli—deauthenticating by local choice (Reason: 3=DEAUTH_LEAVING)

asked 2015-10-18 10:08:16 -0500

emilyhorsman gravatar image

updated 2016-01-17 21:05:46 -0500

mether gravatar image

I'm trying to connect to a wireless network with nmcli. It's a fresh install of Fedora 22 Server and the connection worked correctly during the installation.

# uname -a
Linux localhost.localdomain 4.0.4-301.fc22.x86_64 #1 SMP Thu May 21 13:10:33 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

# nmcli dev
DEVICE     TYPE      STATE         CONNECTION
eno1       ethernet  connected     eno1
wlp0s20u4  wifi      disconnected  --

# nmcli con
NAME     UUID                                  TYPE             DEVICE
Netgear  cc32a76f-d8b4-4fe8-819f-77938b9ba298  802-11-wireless  --
eno1     6156f346-ba44-46f4-8b34-d0a7851e4f20  802-3-ethernet   eno1

I had to do some configuration to create a connection and get to this point:

$ dnf install -y NetworkManager-wifi
$ systemctl restart NetworkManager
$ iwconfig
$ ip link set wlp0s20u4 up
$ nmcli device wifi list
$ nmcli con add con-name Netgear ifname wlp0s20u4 type wifi ssid SSID
$ nmcli con modify Netgear wifi-sec.key-mgmt wpa-psk
$ nmcli con modify Netgear wifi-sec.psk PASSPHRASE

Running nmcli con up Netgear yields Error: Connection activation failed.

This is the relevant output from dmesg

[  605.013273] wlp0s20u4: authenticate with 74:44:01:51:3b:65
[  605.034389] wlp0s20u4: send auth to 74:44:01:51:3b:65 (try 1/3)
[  605.046585] wlp0s20u4: authenticated
[  605.046747] wlp0s20u4: associate with 74:44:01:51:3b:65 (try 1/3)
[  605.061571] wlp0s20u4: RX AssocResp from 74:44:01:51:3b:65 (capab=0x411 status=0 aid=6)
[  605.062324] wlp0s20u4: associated
[  650.057157] wlp0s20u4: deauthenticating from 74:44:01:51:3b:65 by local choice (Reason: 3=DEAUTH_LEAVING)
[  650.069019] cfg80211: Calling CRDA to update world regulatory domain
[  650.074780] cfg80211: World regulatory domain updated:
[  650.074783] cfg80211:  DFS Master region: unset
[  650.074784] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[  650.074786] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[  650.074787] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[  650.074788] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[  650.074790] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[  650.074791] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[  650.074793] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[  650.074794] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[  650.074796] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[  650.074927] cfg80211: Calling CRDA for country: CA
[  650.076318] cfg80211: Regulatory domain changed to country: CA
[  650.076320] cfg80211:  DFS Master region: FCC
[  650.076321] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[  650.076322] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 3000 mBm), (N/A)
[  650.076323] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 1700 mBm), (N/A)
[  650.076324] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2400 mBm), (0 s)
[  650.076325] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2400 mBm), (0 s)
[  650.076326] cfg80211:   (5735000 KHz - 5835000 ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2015-10-18 12:53:08 -0500

emilyhorsman gravatar image

Got this to work by setting an IPv4 address manually and disabling IPv6.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-10-18 10:06:58 -0500

Seen: 2,126 times

Last updated: Oct 18 '15