Ask Your Question
0

Make downgrade permanent

asked 2015-10-16 12:30:00 -0600

alfC gravatar image

updated 2015-10-16 12:34:03 -0600

I find that the new version gedit (3.16.4-1.fc22) is broken (hangs in my system at least). Since this is an essential tool for me, I decided to downgrade to the previous version3.16.1-1.fc22)

$ sudo dnf donwgrade gedit

perfect, no it works. However when I try to update/upgrade the system

$ sudo dnf upgrade

it keeps asking me if I want to upgrade gedit again. How can I make this downgrade permanent (or quasi permanent)? So that I am not asked again about upgrading gedit (together with the rest of the upgrades).

If it is possible, how the "lock" can be lifted later? for example if a newer newer version appears.

edit retag flag offensive close merge delete

Comments

1

I know you need a fix to be able to do your work, so I think @yolo's answer is prefect, but have you considered to file a bug report against gedit? In that way the rest of the users will benefit from the eventual upstream fix.

skytux gravatar imageskytux ( 2015-10-16 12:59:54 -0600 )edit
1
alfC gravatar imagealfC ( 2015-10-16 13:42:00 -0600 )edit

I confirmed it is this bug https://bugzilla.gnome.org/show_bug.c... . A workaround is to do this: $ cd ~/.local/share/ $ mv recently-used.xbel recently-used.xbel.backup

alfC gravatar imagealfC ( 2015-10-19 00:52:23 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2015-10-16 12:54:19 -0600

You can exclude the gedit package for each update in adding the argument exclude : sudo dnf upgrade --exclude=gedit

Or for permanent exclusion, edit the dnf config file /etc/dnf/dnf.conf and add this line with the package to exclude : exclude=gedit

edit flag offensive delete link more

Comments

Thanks, I will have to remember to add --exclude=gedit all the time, it seems.

alfC gravatar imagealfC ( 2015-10-16 13:42:33 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2015-10-16 12:30:00 -0600

Seen: 108 times

Last updated: Oct 16 '15