Ask Your Question
0

Fedora 23 Beta. System can't recover after dnf update.

asked 2015-10-15 13:26:21 -0600

karierowicz gravatar image

updated 2015-11-10 22:28:59 -0600

mether gravatar image

"Oh no! Something has gone wrong. A problem has occured and the system can't recover. Please contact a system administrator". I did my first Fedora 23 beta update. After a reboot I am getting that error screen after system loads everything with [OK] flag and logging menu should be loaded. Using the old kernel version does not help. I am using fedora as virtual machine (by Virtual Box). I tried 2 times with reinstalling the whole system. Any ideas how can I solve it?

edit retag flag offensive close merge delete

Comments

2

By any chance are you able to log in to single mode and check error logs/system logs.

Allen gravatar imageAllen ( 2015-10-15 13:33:26 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-11-20 09:02:08 -0600

basic6 gravatar image

updated 2015-11-26 05:47:31 -0600

Sounds like the Gnome error screen.

This probably won't work anymore - but it used to be possible to simply close this fullscreen warning window by hitting Alt+F4.

Also, since this is a VirtualBox VM, try disabling graphics (2D and 3D) acceleration (VM settings), maybe Gnome is trying to show fancy 3D effects and is failing.

Otherwise, I recommend installing the MATE desktop environment, which is basically a fork of Gnome 2. It's simple and generally better than Gnome 3 if you don't care about huge icons, minimalized guis with no functionality and visual effects and instead just want a lean desktop environment (what Gnome 2 used to be). Before logging in, switch to a text console with Ctrl+Alt+F2 and log in as root (or as you and use sudo -s to become root). then:

dnf install @MATE

This installation will take a couple of minutes. Afterwards, log out of the text console (exit) and restart your display/login manager (switch back with Ctrl+Alt+F1) or simply reboot the system. Next time you log in, there will be a menu listing the installed desktop environments. Select Mate, log in and you should be good.

edit flag offensive delete link more

Comments

Actually, since it's your computer, and you installed Fedora, you should know the root password. Once you're at the text console, just log in as root, do what you need, and log out. Then, either go back to the GUI or reboot. BTW, that's Ctrl-Alt-F2, not Shift.

sideburns gravatar imagesideburns ( 2015-11-20 14:18:29 -0600 )edit

Thanks, I've fixed the keyboard shortcut.

basic6 gravatar imagebasic6 ( 2015-11-26 05:48:44 -0600 )edit

Question Tools

Stats

Asked: 2015-10-15 13:26:21 -0600

Seen: 744 times

Last updated: Nov 26 '15