Ask Your Question
0

steal my focus for fedeora 18

asked 2013-01-18 07:45:35 -0500

oddasee gravatar image

updated 2014-09-29 04:48:18 -0500

mether gravatar image

Fed 17 had a gnome-extension called "steal my focus". Some of you may not agree with it's use, but when I transfer info from one app to another I DO WANT to transfer the window focus immediately to the receiving app. I definitely do not want to hit the notification area as it means moving my mouse where I DON'T want it. Any news on how I can accomplish the same thing with fedora 18?

Thanks in advance.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2013-01-18 09:22:38 -0500

domg472 gravatar image

updated 2013-01-18 09:26:08 -0500

I suppose you could install it from here:

https://extensions.gnome.org/extension/234/steal-my-focus/

A comment there mentions that one should be able to make it work by editing the metadata.json file in ~/.local/share/gnome-shell/extensions/"EXTENSION". Add version 3.6 to shell-version. For example:

  "shell-version": [
    "3.2", 
    "3.4", 
    "3.6"
  ],

After that: alt-F2, r to reload gnome-shell

edit flag offensive delete link more
0

answered 2013-01-18 11:16:46 -0500

oddasee gravatar image

Hello DGrift:

Thanks for the info. The extension does not install via the gnome-extension website.

I looked at MANUALLY installing according to:

http://howto.wired.com/wiki/ManuallyInstallGnome3Extensions

However autogen.sh failed with this message: "C compiler cannot create executables". The log file says gcc has no input files. The command I used was:

./autogen.sh --prefix=$HOME/.local --enable-extensions="steal-my-focus"

FROM WHAT I CAN GATHER ... (perhaps) I simply have to place the .js and .json files ( from https://github.com/kagesenshi/gnome-shell-extension-stealmyfocus ) into the folder:

$HOME/gnome-shell-extensions/steal-my-focus

then reload the shell with alt-f2 "r", which didn't work either. I also tried renaming the file ".json" file to ".json.in" to no effect.

Any other suggestions?

Thanks for your reply.

edit flag offensive delete link more
0

answered 2013-01-18 15:34:11 -0500

oddasee gravatar image

THANK YOU VERY MUCH DGRIFT:

You were correct on all scores and the extension is working now that files are in the right directory!

Best Regards

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-01-18 07:45:35 -0500

Seen: 367 times

Last updated: Jun 06 '13