Ask Your Question
0

Cannot adjust screen brightness in Lenovo T530 in Fedora 23

asked 2015-10-11 19:48:02 -0500

callkalpa gravatar image

updated 2015-10-12 20:16:37 -0500

mether gravatar image

I am using ThinkPad Lenovo T530 laptop and I am on Fedora 23 beta. I cannot adjust my screen brightness with the shortcut keys. I tried several options like appending acpi_backlight=vendor to GRUB_CMDLINE_LINUX but didn't work. Automatic brightness adjustment that comes with GNOME 3.18 is also not working (I am not sure whether my laptop has a light sensor).

Any help to get this fixed is highly appreciated, the brightness is so high that it hurts eyes when working for hours.

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
1

answered 2015-10-12 01:47:55 -0500

Kord gravatar image

For me this was not working either, on nvidia binary blobs, what you can try is to install xbacklight, then to dim the screen: xbacklight -set 40 (replace 40 with the level of brightness that suits you). Hope this helps.

edit flag offensive delete link more

Comments

Thanks a lot, it worked !

callkalpa gravatar imagecallkalpa ( 2015-10-13 04:29:49 -0500 )edit
0

answered 2016-01-15 17:07:01 -0500

lyimmi gravatar image

Hi,

I have a T410s with intel and nvidia VGA. I have set the nvidia cart in bios as the main graphics card. After installing the proprietary driver for it the brightness functions stopped working.

I use Fedora 23, KDE plasma, nvidia driver 340.96.

My solution:

  • Edit the /etc/X11/xorg.conf
  • Find the Section "Device" Added two lines at the end of the section:
  • Option "NoLogo" "true"
  • Option "RegistryDwords" "EnableBrightnessControl=1"

Not sure if this is the "correct" solution but the Fn+HOME / END keys are working and the KDE slider works as well.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-10-11 19:48:02 -0500

Seen: 1,450 times

Last updated: Oct 12 '15