Ask Your Question
0

DNF: conflict with lash packages

asked 2015-10-05 09:38:15 -0600

florian gravatar image

updated 2015-10-05 10:13:50 -0600

Running sudo dnf upgrade, I do get the following conflict/error with package lash.

Any ideas how to deal with this?

Error: Transaction check error:
  file /usr/share/doc/lash/lash-manual/lash-manual.html conflicts between attempted installs of lash-0.5.4-22.fc22.i686 and lash-0.5.4-22.fc22.x86_64

Why do I have both the .i686 and the x86_64 package installed on my system (4.1.7-200.fc22.x86_64)?

...
(29/54): lash-0.5.4-22.fc22.x86_64.rpm            3.8 MB/s | 158 kB     00:00    
(30/54): lash-0.5.4-22.fc22.i686.rpm              3.6 MB/s | 159 kB     00:00  
...

(For now I just skipped upgrade of lash using dnf upgrade --exclude lash)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-10-05 09:52:58 -0600

aeperezt gravatar image

Best way is to remove the packages with conflict

sudo dnf remove lash

After that you can continue with your upgrade.

edit flag offensive delete link more

Comments

Yea but there is a reason why I do have lash on my system. Some software probably uses it. Or do you mean just removing lash.i686 and keep lash.x86_64? Or remove it completely and reinstall it? (Upgrade process itself is not a problem, I ran dnf upgrade --exclude lash)

florian gravatar imageflorian ( 2015-10-05 10:16:26 -0600 )edit

You can remove the i686 specially since the conflict is on the manuals.

aeperezt gravatar imageaeperezt ( 2015-10-05 10:34:10 -0600 )edit

@aeperezt: Thanks, I just removed lash.i686.

florian gravatar imageflorian ( 2015-10-05 20:49:53 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2015-10-05 09:38:15 -0600

Seen: 658 times

Last updated: Oct 05 '15