Ask Your Question
1

Unable to get a list view in Nautilus

asked 2015-10-04 21:01:23 -0600

jflory7 gravatar image

I am using the Fedora 23 beta and just did a fresh wipe-and-install on my laptop. I originally had upgraded using dnf but decided to do a fresh install for a variety of reasons.

When I upgraded, the Nautilus file manager maintained my preferred list view for my files. However, when I was using the fresh installation, the default choice were icons. I went into the Nautilus preferences and checked this box:

My preferences in Nautilus

However, this did not change anything, even when restarting the program and even rebooting the entire computer (the setting persisted).

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
4

answered 2015-10-08 14:21:11 -0600

florian gravatar image

updated 2015-11-21 23:40:30 -0600

Try this...

  1. Start dconf-editor (if not present yet, install it: sudo dnf install dconf-editor),
  2. Navigate to the key org.gnome.nautilus.preferences,
  3. Change the value of default-folder-viewer to list_view.
  4. Restart nautilus, or better logoff and login again. and then start nautilus. That should do it...

...or alternatively, you could just run this simple command to set a the right value for the key: dconf write /org/gnome/nautilus/preferences/default-folder-viewer "'list_view'".

edit flag offensive delete link more

Comments

4

Or without dconf: gsettings set org.gnome.nautilus.preferences default-folder-viewer 'list-view'

masteroman gravatar imagemasteroman ( 2015-10-08 14:51:42 -0600 )edit
1

@masteroman: Yes, you are right. gsettings does the exact same but maybe makes it a bit easier because you don't have to install dconf. @jflory7: You may want to use the gsettings set ... command if you plan not to use/install dconf and/or dconf-editor.

florian gravatar imageflorian ( 2015-10-08 16:29:41 -0600 )edit
1

@Florian: I believe it should just be dconf write /org/gnome/nautilus/preferences/default-folder-viewer "'list_view'" (sans sudo) otherwise it would change the setting for the root user. I've been messing around with dconf a lot lately. -_-

MetaNova gravatar imageMetaNova ( 2015-11-21 00:08:41 -0600 )edit

@MetaNova: yes, you are right. Thanks for the hint. Let me change it in the answer..

florian gravatar imageflorian ( 2015-11-21 23:40:14 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2015-10-04 21:01:23 -0600

Seen: 889 times

Last updated: Nov 21 '15