Ask Your Question
0

nvidia gt 980m

asked 2015-10-04 14:28:39 -0600

Juan Alpizar gravatar image

updated 2015-10-06 07:37:18 -0600

Some weeks ago I bought a new laptop, an MSI Dominator Pro G72 which included this new card. While working smooth as silk on Windows, my main OS use to be a Linux distribution (being Fedora the one I've been using the past year) so I proceeded to install Fedora on it.

The problem was the video card didn't seem to be supported by default (I was getting no animations at all on gnome transitions and so on) so after reading for a while, I proceeded to install the nvidia video drivers from RPM Fusion, since it seemed the easier and faster way to get the job done.

The drivers installed successfully, however next time I restarted Fedora I couldn't access any Graphic Environment: when the laptop starts to boot and the Fedora logo fills up, the screen goes into terminal mode with the text shown in the following picture: image description

and doesn't pass to that point, there are no errors, but the Gnome doesn't seems to be starting either even after typing service gdm start or service gdm restart as root user.

I'm using the latest kernel release available (4.1.8-200 according to uname) and the latest driver from RPM Fusion (352.41) is there any additional consideration I need to take after the driver installation in order to get it working I'm skipping?

EDIT: some additional information I retrieved from @sideburns comments (sorry for the long images I can't directly copy and paste them)

image description image description image description

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-10-04 14:52:52 -0600

sideburns gravatar image

Welcome to ask.fedora! If all you did was install the appropriate kmod-nvidia and reboot, that's what's wrong. There's a tad more that needs to be done, as you can see here. You may not need to blacklist the OSS nouveau drivers, but you do need to have all of the appropriate packages installed. Good luck, and keep us informed.

edit flag offensive delete link more

Comments

Thanks! I'll check it out and will update the progress when I'm back from work :)

Juan Alpizar gravatar imageJuan Alpizar ( 2015-10-05 02:57:54 -0600 )edit

@sideburns sadly after checking I had done most of those steps. The thread seems to be a bit old and some may not be needed anymore (as far as I know I don't need the PAE part on a 64 bit processor and kernel right).

Just for clarification, I ran the following commands from the link you posted:

dnf update kernel\* selinux-policy\*dnf install akmod-nvidia xorg-x11-drv-nvidia-libsmv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img

dracut /boot/initramfs-$(uname -r).img $(uname -r)

and reboot, I'm still at the same point :(

Juan Alpizar gravatar imageJuan Alpizar ( 2015-10-06 07:29:05 -0600 )edit

You use the section that's appropriate for your kernel. If your kernel is x64, you only use those parts. You may want to use dnf erase \*nvidia* and reboot, because that will get you back to where you started, then try again with a clean slate.

sideburns gravatar imagesideburns ( 2015-10-06 11:45:00 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2015-10-04 14:28:39 -0600

Seen: 152 times

Last updated: Oct 06 '15