Ask Your Question

Fedora 20 stuck in Emergency Mode

asked 2015-09-27 08:40:27 -0600

jerrybtw gravatar image

My laptop which ran fine with Fedora 20 until this morning now invariably boots into emergency mode. I never set a root password and I cannot advance beyond the emergency mode prompt. How do I go about fixing this?

edit retag flag offensive close merge delete


Welcome to ask.fedora. As far as I'm aware, part of installing Fedora is setting the root password; how did you manage to skip this step?

sideburns gravatar imagesideburns ( 2015-09-27 13:00:34 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2015-09-27 17:57:34 -0600

updated 2015-09-27 18:06:40 -0600

Unless you inherited your system or something, you definitely set a root password during installation. As sideburns notes, it's mandatory. If you've forgotten the password or for some other reason do not know it, you can try booting your system straight into /bin/bash from the bootloader or using Fedora 22 Live media to boot into rescue mode. Instructions covering both procedures are here.

Try the bash solution first, and if that fails for some reason, try the rescue option. If you can boot into bash directly, you can resolve the issue by simply using the passwd command as you would from a normal boot, but you won't be prompted for a root password. If you boot into rescue mode, you should be able to chroot into your old OS (/mnt/sysimage) and use the passwd command to set your root password.

Of course, you need to figure out why your system will only boot into emergency mode. If you need help with that, you can post another question once you've checked your journal and kernel ring buffer (dmesg) and whatnot for information about your system's problem.

edit flag offensive delete link more

Question Tools


Asked: 2015-09-27 08:40:27 -0600

Seen: 991 times

Last updated: Sep 27 '15