Ask Your Question
1

How to stop kernel ext4 journaling thread

asked 2012-06-07 00:39:12 -0500

WayneP gravatar image

updated 2012-08-16 06:31:04 -0500

hhlp gravatar image

Recently I wanted to manually run fsck on /home, so I unmounted it (successfully). But fsck claimed the device was busy! So it was, by a kernel thread. You can't kill -9 those. Shouldn't such threads stop when the associated device is unmounted? If not, how does one stop it (or better, how should one run fsck on an ext4 FS)?

What I ended up doing was:

   # touch /forcefsck; reboot

But is this an ext4 and/or kernel bug, or have I missed something? My work-around doesn't allow me to run fsck with other options, or interactively.

Here's my system info, if it helps (Note I have remounted /home):

$ mount |grep sda5<br>
/dev/sda5 on /home type ext4 (rw,nodev,relatime,seclabel,user_xattr,acl,barrier=1,data=ordered,usrquota)<br>
$ ps -ef | grep sda5<br>
root       626     2  0 01:01 ?        00:00:00 [jbd2/sda5-8]<br>
$ rpm -q e2fsprogs<br>
e2fsprogs-1.41.14-2.fc15.i686<br>
$ uname -a<br>
Linux XXXXXX 3.3.7-1.fc16.i686.PAE #1 SMP Tue May 22 14:07:22 UTC 2012 i686 i686 i386 GNU/Linux<br>
$ lsb_release -a<br>
LSB Version:    :core-4.0-ia32:core-4.0-noarch<br>
Distributor ID: Fedora<br>
Description:    Fedora release 16 (Verne)<br>
Release:        16<br>
Codename:       Verne
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-08-14 11:27:29 -0500

ZenDark gravatar image

When I need to work with the /home disk first I always switch to single user level.

telinit 1

or

systemctl rescue

After that i can umount/check/resize my /home disk without any problems.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-06-07 00:39:12 -0500

Seen: 1,427 times

Last updated: Aug 16 '12