Ask Your Question
-1

FC17 - Unable to Modify default grub.cfg entry

asked 2013-01-19 06:24:40 -0500

jkpaye gravatar image

updated 2014-09-30 23:17:34 -0500

mether gravatar image

Hi,

Running FC17. I am attempting to track some issue with systemd, and need to change kernel options for my default grub entry to remove rhgb and quiet. I have modified the line "GRUBCMDLINELINUX_DEFAULT" in /etc/default/grub, and removed these options. I then generate the configuration with "grub2-mkconfig -o /boot/grub2/grub.cfg". The resulting configuration is unbootable, and contains neither options from "/etc/default/grub", nor from "/etc/grub.d/*".

Can anyone shed some light on my issue here?

Thanks,

Joshua

edit retag flag offensive close merge delete

Comments

I've done that before and it sounds like you're doing everything right. Can you post the resulting /boot/grub2/grub.cfg?

mitchenerg gravatar imagemitchenerg ( 2013-08-03 16:43:10 -0500 )edit

One thing to watch out for: I frequently use jed to edit /etc files, and it sometimes inserts line breaks as I type. (M-x no_mode deactivates that behavior.) I've broken grub2.cfg that way before: The text editor splits the long string of options into a new line at a space so grub2-mkconfig generates a garbled grub2.cfg.

mitchenerg gravatar imagemitchenerg ( 2013-08-03 16:45:52 -0500 )edit

I'd rather ask for /etc/default/grub

As i understand it, you had deleted the GRUB_COMMAND_LINUX. IF that line is missing or incorrect, you wont be able to boot.

sea gravatar imagesea ( 2013-09-18 10:09:18 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-10-04 09:39:41 -0500

Hi: For me have always worked this

sudo su -
grub2-mkconfig > /boot/grub2/grub.cfg

Hope it works.

Kind regards

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-01-19 06:24:40 -0500

Seen: 322 times

Last updated: Oct 04 '13