Ask Your Question
1

Steam won't work at all? [closed]

asked 2015-09-19 14:46:56 -0600

Innectic gravatar image

I can't appear to get steam to work on Fedora 23 beta, no matter what solution I find online it doesn't work.

Error:

Running Steam on fedora 22 64 bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam) / version(0)
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast

What I've tried:

  1. I've tried Steam's installer on their site.
  2. I've tried installing Steam from other repositories.
  3. I've tried installing Steam using PlayOnLinux
  4. Reinstalling drivers
  5. Searching the interwebs for solutions for 2 hours trying all of the solutions

If it matters, I'm using a GTX 660. I hear that this might matter as well, I'm using the 340 nvidia driver.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by florian
close date 2016-04-05 21:05:45.466666

3 Answers

Sort by ยป oldest newest most voted
1

answered 2015-12-06 17:55:47 -0600

LooseTux gravatar image

I had the exact same error on Fedora 23 (64bit) with an Nvidia GTX 760 card. It only happens when running with the proprietary Nvidia drivers installed. Steam launches with the open source drivers.

I installed the 32-bit libraries included in the RPM Fusion repo:

dnf install xorg-x11-drv-nvidia-libs.i686

and now Steam works :)

If you install your Nvidia drivers from RPM Fusion and run that command, it should work. Or it did for me anyway.

edit flag offensive delete link more

Comments

Unfortunately when I installed this package with existing proprietary Nvidia drivers (v361.28), my system was hosed. Got the "Uh oh! Something went wrong." on reboot and I had to go into a virtual console to uninstall the drivers from RPM Fusion and re-install the other drivers.

crtelinde gravatar imagecrtelinde ( 2016-03-12 13:16:36 -0600 )edit

exact same think happened to my system when i ran this command.

I did a fresh install of fedora 23 and steam works only with the nouveau drivers. As soon as you switch the drivers you get the libGL errors.

I also tried running

dnf install xorg-x11-drv-nvidia-libs

this installed the 64 bit drivers since i'm running a 64 bit OS. But the same libGL error output happens.

happymonkey gravatar imagehappymonkey ( 2016-04-05 20:09:53 -0600 )edit

I had the proprietary nvidia drivers installed via rpmfusion, but only the 64 bit ones. When I followed this instruction and also installed the 32 bit ones from rpmfusion steam started working. Thank you!!!

patrick gravatar imagepatrick ( 2016-05-21 11:30:18 -0600 )edit
0

answered 2015-09-20 15:45:57 -0600

Albeit written for Ubuntu, this solution also worked for me on Fedora 22 using radeon and fglrx drivers:

http://askubuntu.com/questions/614422...

edit flag offensive delete link more

Comments

Sadly this didn't help me. I got rid of the libstd++ libs (and had done it before trying to fix it) and it didn't help. I had the proprietary nvidia drivers installed via rpmfusion, but only the 64 bit ones. When I followed this instruction and also installed the 32 bit ones from rpmfusion steam started working. Yay!!!

patrick gravatar imagepatrick ( 2016-05-21 11:31:52 -0600 )edit
0

answered 2015-12-04 07:33:19 -0600

I've observed same behavior with nvidia driver MISSING 32bit libraries. After 32bit libraries install steam run as it supposed to do.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-09-19 14:43:42 -0600

Seen: 4,669 times

Last updated: Sep 19 '15