Ask Your Question
0

Can't change permissions on files on my WD Passport ?

asked 2012-02-04 23:45:05 -0600

jski gravatar image

I just loaded PETSc on my new WD Passport and tried:

$ ./configure

and got:

bash: ./configure: Permission denied

$ ls -l configure -rw-------. 1 jski jski 340 Aug 31 12:33 configure

Tried: $ chmod 777 configure

No good.

Tried: $ su -c 'chmod 777 configure'

No good.

What gives?

How can I change permissions on files on this drive/device?

---John

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-02-07 06:12:41 -0600

ryran gravatar image

As bochecha said, you really should give more information, but I've got a hunch you're dealing with an NTFS disk. If that is the case, one of your options is to create a directory called .NTFS-3G (note the dot) at the root of the ntfs partition and then create a file in that dir named UserMapping -- the file should contain one line:

::S-1-5-21-3141592653-589793238-462643383-10000

Then, unmount the drive and plug it back in. You should have wide-open permissions. See this fedoraforum thread for more detail and other options (skip down to post #12).

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-02-04 23:45:05 -0600

Seen: 1,642 times

Last updated: Feb 07 '12