Ask Your Question
2

How to disable shift+space layout switching?

asked 2015-08-31 13:01:54 -0600

Mykola gravatar image

Can't find an option to disable that neither in Settings | Keyboard | Shortcuts, nor in Gnome Tweak Tool | Typing.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2015-09-02 09:31:24 -0600

Mykola gravatar image

Removing ~/.config folder fixed the issue for me. Be careful! This resets your gnome settings.

edit flag offensive delete link more

Comments

Any clue where it was defined there? And why? Maybe no need to remove the entire ~/.config folder. This answer will helpful for others!

florian gravatar imageflorian ( 2015-09-02 11:50:27 -0600 )edit

@Florian, In fact removing or renaming ~/.config/dconf/user file and restarting gnome session proved to be sufficient. No clue as to why <shift>space worked that way or where it was defined. At least for now.

Mykola gravatar imageMykola ( 2015-09-03 02:05:46 -0600 )edit
2

answered 2015-08-31 15:28:03 -0600

florian gravatar image

updated 2015-08-31 15:29:35 -0600

Go to Settings --> Keyboard --> Shortcuts. Under Input Methods (or so, second from the bottom) you see the shortcuts for changing the keyboard layout.

By default, this should be "Super" (aka Windows)-key + Space. (not shift + space). There you can put (almost) anything you want...

edit flag offensive delete link more

Comments

Here is how Settings --> Keyboard --> Shortcuts looks like on my PC. http://i59.tinypic.com/107un9d.png As you can see, there is no Shift + Space shortcut in the list yet it still changes layout. And the question is how do I get rid of that unwanted behavior?

PS: Can't find Shift + Space shortcut in dconf-editor under org | gnome | desktop | wm | keybindings either.

Mykola gravatar imageMykola ( 2015-09-01 05:49:16 -0600 )edit

That is very strange. Shift should never trigger any shortcut. The modifiers are Super or ALT or CTRL, NOT Shift.

florian gravatar imageflorian ( 2015-09-01 08:46:36 -0600 )edit

@Florian I know this is strange and It's bugging me so hard. Because I tend to press space a lot while still holding Shift, expecting to type white space, not change layout. Although I'm getting used to it every day :)

Mykola gravatar imageMykola ( 2015-09-01 09:45:53 -0600 )edit

@Mykola: In my opinion this is a bug. You should consider reporting it on bugzilla

florian gravatar imageflorian ( 2015-09-01 10:14:43 -0600 )edit

Filed a bug report at bugzilla here https://bugzilla.redhat.com/show_bug.... .

Mykola gravatar imageMykola ( 2015-09-02 05:40:06 -0600 )edit
0

answered 2017-05-16 14:53:09 -0600

This is most likely caused by adding "Left Alt + Left Shift" switching method during installation. Workaround for me was to install gnome-tweak-tool and remove that assignment.

It's rather interesting bug as those two hotkey combinations are quite different.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2015-08-31 13:01:54 -0600

Seen: 1,059 times

Last updated: Sep 02 '15