Ask Your Question
3

CUPS Problem

asked 2015-08-11 13:28:10 -0600

cdithaca gravatar image

I tried numerous times to install my Brother MFC-J470DW printer in Fedora 22. After several attempts using both the Gnome Printer Settings function, System-Config-Printers, and the Brother software downloaded from their web site, I was unable to get the network printer to connect - although Simple Scan recognized the printer.

Now I cannot open either Print utility and when I go to http://localhost:631/ , it operates very slowly and when I click the Printers link, I get a broken page that says "Success" but it doesn't list any printers. I am thinking possibly I should re-install CUPS, but am not sure how to do that or whether that would fix the problem.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2015-08-14 12:35:57 -0600

cdithaca gravatar image

I found a couple of issues finally. One was that cups had a Maximum Users set to 1 so I had to modify cups.conf and restart the cups.service to fix that one. Then I setup the printer as ipp and pointed to the IP address shown on the Brother Printer screen. Then SELinux was stopping me so figured out I had to run "setsebool -P cups_execmem 1" as root. After that I was able finally to print.

edit flag offensive delete link more

Comments

Good job. SElinux is the fist stop with fedora have any non understandable bug!

speedytux gravatar imagespeedytux ( 2015-08-17 14:56:44 -0600 )edit
0

answered 2015-08-12 13:48:08 -0600

updated 2015-08-12 13:49:45 -0600

I found this on Archlinux Wiki page for CUPS, and in the past was helpful to me that I have a Samsung printer

Note: hplip depends on foomatic-db-engine which prevents the drivers list from appearing when a printer is added to CUPS via the web user interface (following error : "Unable to get list of printer drivers"). Possible workarounds: Either: Install hplip first, then retrieve the PPD file that matches your printer from /usr/share/ppd/HP/. Next, remove hplip entirely as well as any unnecessary dependencies. Finally, install the printer manually using the CUPS web UI, selecting the PPD file you retrieved, and then re-install hplip. After a reboot, you should have a fully working printer. Or: Remove hplip, foomatic-db and foomatic-db-engine along with any unnecessary dependencies. Reinstall hplip and restart CUPS. Install your printer using the CUPS web UI, which should now be able to find the drivers automatically. No reboot needed.

edit flag offensive delete link more
0

answered 2018-02-08 08:09:49 -0600

With Fedora 27 the only problem I had with CUPS working for other computers (Ubuntu's and Win10's) was with the Firewall.

The clue was trying to conect to the CUPS admin program from the Win10 box browser. http://OfficeRoom20:631 The browser wouldn't connect to it. OfficeRoom20 is the machine running Fed 27.

As soon as I entered "firewall-cmd --add-service=ipp" on the Fedora machine ... the CUPS related printer was available to all machines.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-08-11 13:28:10 -0600

Seen: 895 times

Last updated: Aug 14 '15