Ask Your Question
1

Wired connection fails due Camput Network?

asked 2015-07-29 13:09:35 -0600

Cyghost gravatar image

updated 2015-07-29 15:34:59 -0600

Hello guys,

So I have been through all the Threads, Questions here and checked all the possible answers to find a solution for me. I wont post my snippets here, just some take-out: - If i set DHCP Auto I cannot ping to my router nor outside - If i set Manually IP, I can ping my router but not outside (so no google.com nor 8.8.8.8, etc.) - My Ethernet Card is detected (ifconfig) and drivers recognized / installed (lspci -v) (possible issue because it is R8169?)

I have tried to play around with NetworkManager, restarting, unplugging the cable, etc. Nothing worked. This happened on: ArchLinux, Kali Linux and now on Fedora linux.

Once I got it working on Kali Linux but rather randomly than with strategy, but after reboot it did not work anymore there too.

I won't ask for your ideas on how to solve this one, because I will probably just delete and give up on Linux here, but I would like to ask, is this a common problem on Campus Networks ? Is it possible that they do not allow / support Linux OS for Networking ?

EDIT: Since you guys are really nice with help, I will also put some effort to this question, maybe we can find solution.

LINUX OS: Fedora 22

Dual-boot: Yes - with Windows 7 Ultimate (here the Internet works fine)

Network Driver: R8169

Some outputs:

**/etc/resolv.conf:**

# Generated by NetworkManager
search uni-mb.si
nameserver 164.8.100.100
nameserver 164.8.1.100

/etc/networks:
default 8.8.8.8
loopback 127.0.0.0
link-local 169.254.0.0

**/etc/sysconfig/network-scripts:**

HWADDR= *{correct one}*
TYPE="Ethernet"
BOOTPROTO=dhcp
DEFROUTE="yes"
IPV4_FAILURE_FATAL="no"
IPV6INIT=no
IPV6_AUTOCONF="yes"
IPV6_DEFROUTE="yes"
IPV6_FAILURE_FATAL="no"
NAME=SD08L
UUID="5b82b452-3fec-4aaa-b2fc-f1181228777c"
ONBOOT="yes"
DNS1=*{correct ones - this one I input}*
DNS2=*{correct ones - this one I input}*
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes
PEERDNS=yes
PEERROUTES=yes

**ifconfig:**
enp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet *MY_IP*  netmask *MY_NETMASK*  broadcast 164.8.221.255 **(This one I cannot find inside my Network settings, so dont know what it is)**
        inet6 fe80::d250:99ff:fe55:af8f  prefixlen 64  scopeid 0x20<link>
        ether d0:50:99:55:af:8f  txqueuelen 1000  (Ethernet)
        RX packets 1492  bytes 206232 (201.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 103  bytes 17996 (17.5 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 4  bytes 460 (460.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 4  bytes 460 (460.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

ADDING route print (from Win cmd)

route print

Thanks.

edit retag flag offensive close merge delete

Comments

Campuses are commonly behind proxy. Were proxy settings applied?

NuuN gravatar imageNuuN ( 2015-07-29 14:12:38 -0600 )edit

@NuuN: Thanks for replying.As far as I am aware, we do not use Proxy at our Campus / Students Dorms. I checked with What is my IP website and it says "No Proxy detected".

Cyghost gravatar imageCyghost ( 2015-07-29 14:15:13 -0600 )edit

When you have the connection "up and running" using DHCP, go to the IPv4 Settings tab on your connection and let us know what your IP address and Gateway are. FYI, your Gateway should be your router's IP address.

sideburns gravatar imagesideburns ( 2015-07-29 14:45:10 -0600 )edit

@sideburns: Thanks for helping. My connections is "connected" only when I manually insert the IP, Netmask, DNS, Gateway inside the Network Manager app, when I click on Edit eth0. If I do not give this inputs, it won't even connect. And as said, even though it connects now, the internet is not really working - ping only works locally (router), but cannot ping google or 8.8.8.8

Cyghost gravatar imageCyghost ( 2015-07-29 14:49:25 -0600 )edit

Question what version of Fedora are you running?

aeperezt gravatar imageaeperezt ( 2015-07-29 15:04:38 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-07-29 16:04:45 -0600

Cyghost gravatar image

So guys, I will be answering my question by myself - but this could not be achieved with amazing support I got in the comments below the question.

What fixed it for me:

I had previously installed VirutalBox on my Windows 7, which installed a

VirtualBox Ethernet Adapter

inside the Newtork Adapters. I then uninstalled this one (inside Windows) and went back to check if it helped - in my case, I also had to remove my manual inserted IP, DNS, etc and just live it for Automatic DHCP.

and then .. it WORKED. Curretnly typing this solution with my Fedora 22, really excited!

Thanks for help!

edit flag offensive delete link more

Comments

1

@Cyghost, apologies. I am multitasking repairs and support. Good to see the guys have helped you fix it ๐Ÿ˜

The settings on one interface is designed to be isolated from other interface. Routing or global settings through a daemon or teaming are what I understand would affect multiple interface.

Anyhow, as @sideburns stated, that default route is faulty.

NuuN gravatar imageNuuN ( 2015-07-29 16:19:07 -0600 )edit

Tick your answer please, @Cyghost.

NuuN gravatar imageNuuN ( 2015-07-29 16:42:10 -0600 )edit

Question Tools

Stats

Asked: 2015-07-29 13:09:35 -0600

Seen: 286 times

Last updated: Jul 29 '15