Ask Your Question
4

[Fedora 22] Username prompt during login - hide users list - GDM

asked 2015-07-20 10:14:13 -0600

Sieges gravatar image

updated 2015-07-20 20:34:24 -0600

NickTux gravatar image

Hello,

I've new to Fedora, so please forgive any silly questions.

How can I get a login screen where I have to enter username? Now there is a list of users with pictures and I would rather want a more "classic login" to enter username and password rather than clicking on my picture and entering password. Using Fedora 22.

Thanks!

edit retag flag offensive close merge delete

Comments

KDE? The desktop environments in use are varied. The way you login is usually tied to the spin or desktop environment in use. Is this SDDM?

NuuN gravatar imageNuuN ( 2015-07-20 10:41:46 -0600 )edit

(RANT MODE) For me this has been a real pain. Diverse approaches to remove this always failing (gdm). Now I upgrade from 20 to 22 via fedup, and land in an even worse situation: a user list that overflows from the top and bottom of the screen, and no way to scroll it (apparently). Who designed this "feature" ?. I am just continuing the F23 and look thereafter. This is a shared computer with more than 30 out of a pool of 100+ users. Showing the user names is in fact a bad security practice... and expensive on resources (NFS-mounts all home directories).

David Ramirez gravatar imageDavid Ramirez ( 2015-11-18 17:11:46 -0600 )edit

Follow-up: I got F23 on that desktop. Same situation: user list that overflows top and bottom, is not navigable, doesn't allow selection. Hitting the space bar brings a login box, but this is not the ideal solution... Solved below (see my comment there).

David Ramirez gravatar imageDavid Ramirez ( 2015-11-19 10:18:02 -0600 )edit

2 Answers

Sort by » oldest newest most voted
8

answered 2015-07-20 20:18:45 -0600

NickTux gravatar image

updated 2015-07-21 03:43:31 -0600

Although lightdm is an alternative Display Manager which provides such feature (hiding users list), I do not consider it as a solution to actual question/problem.

You can configure GDM , the Official Fedora/GNOME Display Manager in order to hide users list in login screen,

not only this but also display a (header) message if you want

and disable the restart button too.

Tested and worked as expected in Fedora 22.

First we need to create a folder and a file with specific content.

Open a terminal and execute the following commands:

sudo mkdir /etc/dconf/db/gdm.d 
sudo gedit /etc/dconf/db/gdm.d/01-hide-users

The second command will open gedit editor empty, copy-paste the following content:

[org/gnome/login-screen]
banner-message-enable=true
banner-message-text='ENTER ANY MESSAGE YOU WANT HERE. FOR A NEW LINE USE \n.' 
disable-restart-buttons=true
disable-user-list=true

If you don't want a banner message then do not include the first and second lines at all.

If you don't want to disable the restart button, do not include the relevant line either.

Save the file and return to your terminal.

Now we need to create one more file

sudo gedit /etc/dconf/profile/gdm

again, an empty editor will open, copy-paste the following content:

user-db:user
system-db:gdm

save the file and execute the following command in your terminal

sudo dconf update

Check whether the command executed as it should, a new file(file not folder) should be created inside /etc/dconf/db/ with the name gdm.

ls /etc/dconf/db

should return something like this

gdm gdm.d ibus ibus.d

Restart GDM for the changes to take effect.

sudo systemctl restart gdm

And voilà

image description

Original Size Image

Based on

edit flag offensive delete link more

Comments

Thank you very much for your answer, NikTh :)

However, when executing

sudo update dconf

the terminal returns

sudo: update: command not found

and checing the /etc/dconf/db folder gives a slightly different return

gdm.d  ibus  ibus.d

Any ideas?

Sieges gravatar imageSieges ( 2015-07-21 02:15:27 -0600 )edit

typo: sudo dconf update is the correct command. Fixed.

NickTux gravatar imageNickTux ( 2015-07-21 03:43:00 -0600 )edit
1

Worked perfectly!

Thank you very much!

Sieges gravatar imageSieges ( 2015-07-21 07:59:06 -0600 )edit

Fantastic that this option still exists, even though it's really hard to access. I wonder, how did you find this, is there a secret advanced GDM manual somewhere?

BRPocock gravatar imageBRPocock ( 2015-08-06 13:27:47 -0600 )edit

@BRPocock if you click the "Based on" link, you will see how I found it :-)

NickTux gravatar imageNickTux ( 2015-08-06 13:53:47 -0600 )edit
1

answered 2015-07-20 10:55:35 -0600

BRPocock gravatar image

Note, you can type the first letter(s) of the name to log in.

It looks like gdm has removed the “hide list” option.

However, lightdm is available and works with the default (Gnome) desktop all right, if you want a “retro” look; it looks like in /etc/lightdm/lightdm.conf there's an option: greeter-hide-users = true to force typing the login name.

I believe a quick way to swap that out would be:

sudo dnf install lightdm
sudo nano /etc/lightdm/lightdm.conf

Search for “hide” then insert a line like so:

 # greeter-hide-users = True to hide the user list 
 greeter-hide-users = true
 # greeter-allow-guest = True if the greeter should show a guest login option

Then save, and

sudo systemctl enable lightdm
sudo systemctl disable gdm

At this point, you could probably stop/start the services to swap it live, but if you're not familiar with doing that, it'll be easier to just restart.

edit flag offensive delete link more

Comments

Thanks, BRPocock!

That worked.... sort of :)

Two things: 1) I had to do sudo systemctl disable gdm before sudo systemctl enable lightdm 2) There is still a username list in a dropdown menu, i would like it to be an input box for both username and password without any dropdown menu showing users. I assume it is an option in /etc/lightdm/lightdm.conf ... but which one?

Thanks again :)

Sieges gravatar imageSieges ( 2015-07-20 12:17:53 -0600 )edit

You should use:

greeter-show-manual-login=true
X3MBoy gravatar imageX3MBoy ( 2015-07-20 23:55:36 -0600 )edit

Hmm... Still does not remove the user list...

Sieges gravatar imageSieges ( 2015-07-21 02:11:10 -0600 )edit

Thanks NikTh - this has been a guru answer! It worked for me with Fedora 23, solving the very annoying user list issue (long list overflowing up & down, no navigation on it). Who ever invented this "feature" ? One thing: If I want to redo the configuration, dconf update seems to (silently) fail. The /etc/dconf/db/gdm is not refreshed (e.g. with a new banner text). But if I do: dconf compile gdm gdm.d the gdm file is rebuilt correctly. Thanks a lot - you save the day or even the week!

David Ramirez gravatar imageDavid Ramirez ( 2015-11-19 12:38:48 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2015-07-20 10:13:33 -0600

Seen: 109,804 times

Last updated: Jul 21 '15