How do I change the framebuffer mode?

asked 2015-07-18 21:58:26 -0500

Summit gravatar image

updated 2015-07-19 19:19:13 -0500

mether gravatar image

fbset returns ioctl FBIOPUT_VSCREENINFO: Invalid argument when running something like:
fbset -g 1024 768 1024 768 32 -t 12714 128 32 16 4 128 4
no matter what I try (sudo, explicit database, frame buffer device). I found a way to echo directly to a fb0 parameter in /sys/... , but that was not Fedora documentation and I do not want to be blind on my desktop.
I've been having lot's of trouble setting up a 21:9 2560x1080 monitor. Fedora (and other distros) maxes out at 1920x1080. That being said I'm willing to resort to kernel parameters and even custom kernels if it is necessary.
I suspect the frame buffer because all was well under proprietary Catalyst drivers (good xrandr resolution and all) but the frame buffer mode was strange:
mode "1024x768-76"
# D: 78.653 MHz, H: 59.949 kHz, V: 75.694 Hz
geometry 1024 768 1024 768 32
timings 12714 128 32 16 4 128 4
rgba 8/16,8/8,8/0,8/24
endmode
But I can't even seem to change my frame buffer mode. The mode above is the mode I'm trying to set and I added it to fb.modes. With the radeon drivers, xrandr custom modes (as per EDID) do not work and I believe it's because the frame buffer mode does not seem to change with xrandr.
If you need /var/log/Xorg.0.log or dmesg, please let me know.
Linux Prime 4.0.7-300.fc22.x86_64 #1 SMP Mon Jun 29 22:15:06 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

edit retag flag offensive close merge delete

Comments

But the framebuffer is different from Xorg! Why do you resize the framebuffer? Do you sometimes not use Xorg?

NuuN gravatar imageNuuN ( 2015-07-19 00:25:06 -0500 )edit

@NuuN I'm trying to replicate the settings that the proprietary catalyst driver used. It seems to be the only configuration that works.

Summit gravatar imageSummit ( 2015-07-19 14:33:14 -0500 )edit

@Summit, if I memory serves, the present framebuffer for nouveau is managed by KMS. Maybe you could find options to fit that by researching KMS instead. Look at man drm-kms.

NuuN gravatar imageNuuN ( 2015-07-19 15:32:31 -0500 )edit

@NuuN drm.debug=6 at boot and I found the needle in the haystack. dmesg gives: [ 58.552132] [drm:drm_mode_debug_printmodeline] Modeline 59:"2560x1080" 60 185580 2560 2624 2688 2784 1080 1083 1093 1111 0x48 0xa [ 58.552134] [drm:drm_mode_prune_invalid] Not using 2560x1080 mode: CLOCK_HIGH My monitor is rated for 240MHz (as per monitor-edid)... I'm considering filing a bug.

Summit gravatar imageSummit ( 2015-07-22 16:24:16 -0500 )edit