Ask Your Question
0

gnome gdm fails - modprobe says no nvidia module found

asked 2015-07-11 06:29:12 -0600

pja gravatar image

Hi,

In kernel 4.0.5 and in 4.0.6 gnome gdm (X) fails with a fatal error as modprobe does not find the nvidia module. It is there in /usr/lib/nvidia and in / usr/lib64/nvidia as well as a link in / usr/lib64/xorg/modules/ as a nvidia directory. Also in the drivers directory there is a module nvidia_drv.so. Anyone have any idea why this configuration fails?
The same configuration in kernel 4.0.4 works fine (but does not have sound). PS. I cannot upgrade the kernel anymore without loosing graphics as only 3 versions of the kernel are allowed in /boot, I therefore cannot know if this is sorted in the 4.0.7 kernel now available as an update. Help would be most appreciated.

edit retag flag offensive close merge delete

Comments

If you had installed nvidea propietary video modules you need to reboot and boot with previus kernel, nvidia do not update its kernel module as fas as Fedora do, so when new kernel from Fedora it is posible that it not work with your current configuration you need to reinstall the mode or use akmod-nvidia so it get compile with each update.

aeperezt gravatar imageaeperezt ( 2015-07-11 10:53:20 -0600 )edit

Two questions: first, which version of Fedora are you using and second, how did you install the drivers? Last, I'd like to mention that it's possible to keep more than three kernels, but the instructions depend on whether you're using yum or dnf.

sideburns gravatar imagesideburns ( 2015-07-11 14:30:32 -0600 )edit

Hi Sideburns, I'm running Fedora 22, Kernel 4.0.4-301.fc22.x86_64, drivers were installed by fedup when I upgraded from Fedora 21 where I was using the rpmfusion ones. Since moving to Fedora 22, I'm using the kernel kmod ones I believe. I use yum / yumex for package selection / update.

[Films@127 ~]$ rpm -qa | grep nvidia xorg-x11-drv-nvidia-346.72-1.fc22.x86_64 nvidia-texture-tools-devel-2.0.8-9.fc22.x86_64 xorg-x11-drv-nvidia-libs-346.72-1.fc22.x86_64 nvidia-texture-tools-2.0.8-9.fc22.x86_64 kmod-nvidia-346.72-2.fc22.1.x86_64 kmod-nvidia-4.0.4-301.fc22.x86_64-346.72-2.fc22.1.x86_64

pja gravatar imagepja ( 2015-07-12 03:27:08 -0600 )edit

Hello aeperezt, I don't understand what you mean when you say "need to reinstall the mode...". Could you please explain this to me. As far as akmod is concerned, I was hoping not to have to download the kernel sources and have to recompile at each kernel upgrade. I have been using kmod for some time and had no issues in Fedora 20 until the EOL was anounced and development was slowed down / stopped.

pja gravatar imagepja ( 2015-07-12 03:36:42 -0600 )edit

Since you using kmod you need update kmod every time you have a new kernel mod, Issue here is probably rpmfusion do not have the kmod for the new version of the kernel. If you use akmod it will compile the module for you once you update kernel.

aeperezt gravatar imageaeperezt ( 2015-07-12 10:35:07 -0600 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2015-07-21 14:06:51 -0600

pja gravatar image

Hi all, especially aeperezt, as he finally pointed me in the right direction. I've abandonned using the kmod nvidia modules in favour of the akmod modules recompiled for each new kernel. It's not perfect (as I discovered in 4.0.8 where the module was not compiled) but a quick check for the module in /lib/modules/<kernel>/extra/ tells me before rebooting if the nvidia directory is present & populated or not and from that if the nvidia modules are available or not. It solved my problem. Thanks to all.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-07-11 06:29:12 -0600

Seen: 521 times

Last updated: Jul 21 '15