Ask Your Question
2

Fedora 22 Steam, libGL errors

asked 2015-07-04 19:34:47 -0600

johntate gravatar image

updated 2015-07-07 09:56:24 -0600

mether gravatar image

I have just upgraded from Fedora 22 from 21. I am having trouble running Steam because of some errors from libGL. I have tried both the rpmfusion-nonfree and negativo17 fedora-steam packages. They both get this same error, and I am not sure how to proceed.

[john@fekete ~]$ LIBGL_DEBUG=verbose /usr/bin/steam 
Running Steam on fedora 22 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1433441724)
libGL: screen 0 does not appear to be DRI2 capable
libGL: OpenDriver: trying /usr/lib/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/dri/swrast_dri.so
libGL: Can't open configuration file /home/john/.drirc: No such file or directory.
libGL: Can't open configuration file /home/john/.drirc: No such file or directory.
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast

glxinfo reports that direct rendering is enabled

name of display: :1
display: :1  screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
edit retag flag offensive close merge delete

Comments

Try it:

1) find ~/.steam/root/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" \) -print -delete

2) find ~/.local/share/Steam/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" \) -print -delete
davidva gravatar imagedavidva ( 2015-07-04 23:37:08 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
2

answered 2015-07-21 10:50:58 -0600

Marco Persy gravatar image

try to install this library

sudo dnf install xorg-x11-drv-nvidia-libs.i686

then restart your PC.

edit flag offensive delete link more

Comments

You don't actually need to restart, FYI.

whardaker gravatar imagewhardaker ( 2017-04-20 17:03:08 -0600 )edit
0

answered 2017-05-31 15:19:32 -0600

ssr gravatar image

Thank you very much for the advice to install 32-bit libs! It helped me in Fedora 25 when I updated system and video drivers were also updated and broke Steam.

edit flag offensive delete link more
2

answered 2015-07-05 00:54:27 -0600

geforce gravatar image

updated 2015-07-05 01:01:49 -0600

Try installing the nvidia i686 libs as steam is a 32bit app.

su
dnf install $(rpm -qa --queryformat "%{NAME}\n" *\nvidia\* |grep libs) -x *.x86_64
edit flag offensive delete link more

Comments

1

But this line installs only 64 bit libs. How to install 32 bit libs?

mifth gravatar imagemifth ( 2015-07-25 03:30:19 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2015-07-04 19:34:47 -0600

Seen: 9,079 times

Last updated: May 31 '17