Ask Your Question
1

Many sessions with one user?

asked 2015-07-01 11:36:24 -0600

dstar gravatar image

updated 2015-07-01 12:13:19 -0600

Hi,

Keep in mind I just installed Fedora 22 two days ago and haven't used much Linux before. So, this is a problem that happened to me for the second time now and have no idea why it happened or what to do. After locking my screen (Super+L) I can usually login into my session without problems. But here's what happened: I locked the screen, and when I logged back in, none of the programs I had left running were running - as if I had opened a new session. It seems as if Fedora (or is that a Gnome problem?) creates a new session with the same user (I have only one user besides root on the system, so I just click on the user name on the login screen, enter my password and that's it). However, the original session still seems to be running. Any idea? any suggestion much appreciated - at least a workaround for getting into my original user session would be helpful.

As suggested, I tried the "who" command and noticed three sessions running - tty2 and tty3 besides my terminal session.

I found a way to repeat this (is this a feature?). When I double click twice on the lock screen (yes, 2x double click) instead of scroll up, this happens (maybe I did it by accident or there is another way besides double clicking). However, after this, I can't find a way to go to my original session.

Thank you, David

edit retag flag offensive close merge delete

Comments

1

Welcome to ask.fedora! What you're doing (or should be doing) when the screen locks is unlocking the screen, not starting a new session. If you open a terminal and use the command who you should see two sessions: your GUI session and the terminal. If it's really opening a new session, you'll see three. Please let us know in a comment beneath this or as an edit to your question.

sideburns gravatar imagesideburns ( 2015-07-01 11:44:24 -0600 )edit

Yes, there are three sessions - tty2, tty3 and pts/0

dstar gravatar imagedstar ( 2015-07-01 11:52:20 -0600 )edit

In addition to @sideburns above comments, GDM runs on Wayland in DISPLAY :0. That will be one process running as user gdm, probably id 42. As who may not represent how your sessions work understandably, try loginctl instead. Launched terminals affect the number of user sessions who shows.

NuuN gravatar imageNuuN ( 2015-07-01 14:12:26 -0600 )edit

I'll echo this experience, and my frustration with it. I'll endeavor to not double click and get into this situation to begin with... But is there any way to resume the original session? Is this an issue with the screen lock, or some other problem?

snikle gravatar imagesnikle ( 2015-07-06 21:11:46 -0600 )edit

When I try it, it would seem the double click brings up another instance of a display manager. Does yours have a different pattern wallpaper too? Like a quilt?

Because I always have memory-intensive processes going, I cannot find the time to test it. There is nothing in the journal that helps. So, either avoid double clicking or use Gnome on Wayland. Maybe straight wayland may avoid Xwayland or Xorg from hijacking GDM preferences.

NuuN gravatar imageNuuN ( 2015-07-07 00:50:07 -0600 )edit

4 Answers

Sort by ยป oldest newest most voted
1

answered 2015-07-10 01:11:16 -0600

dstar gravatar image

If anyone has the same problem: Ctrl+Alt+F2 seemed to work to take me back.

edit flag offensive delete link more
0

answered 2015-11-03 06:37:43 -0600

I got the same problem in Fedora 22. After continuing from lunch, i got a new session while the other one prefents my firefox from starting because it is running in the other session.

edit flag offensive delete link more
0

answered 2015-12-04 10:46:59 -0600

I have the same problem running fc22 on vmware player on i686. Ctrl-Alt-F2 works only once. The second time, it does not "restore" the session and hangs with a blank black screen.

edit flag offensive delete link more
0

answered 2015-07-01 14:33:40 -0600

NuuN gravatar image

GDM logs you in via :0. Following that, your Xorg server opens on :1. I do not recall if it is the same when you run Gnome on Wayland. If you are in another session completely, then this may well be :2 onwards.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-07-01 11:35:21 -0600

Seen: 1,361 times

Last updated: Jul 10 '15