Ask Your Question
0

Fedora 22 booting to emergency mode

asked 2015-06-30 17:54:07 -0500

goodyca gravatar image

I have done a fresh install of Fedora 22 on the same computer 4 times. Each time, after using the system from 1 day to 3 days and having successfully rebooted several times, a reboot results in being started in emergency mode. This computer was running Fedora 21 since its release without any problems. I am using an ASUS P9X79 Deluxe motherboard.

At the emergency mode console the following is displayed in yellow:

Ignoring BGRT: invalid status 0 (expected 1)

ata16.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6

ata16.00: irq_stat 0x40000001

ata16.00: cmd a0/01:00:00:00:01/00:00:00:00:00/a0 tag 1 dma 16640 in

Inquiry 12 01 00 00 ff 00res 00/00:00:00:00:00/00:00:00:00:00/00 Emask 0x3 (HSM violation)

Running journalctl -xb has the following lines in red:

Jun 30 14:48:15 mac.localdomain kernel: Ignoring BGRT: invalid status 0 (expected 1)

Jun 30 14:48:15 mac.localdomain kernel: ata16.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6

Jun 30 14:48:15 mac.localdomain kernel: ata16.00: irq_stat 0x40000001

Jun 30 14:48:15 mac.localdomain kernel: ata16.00: cmd a0/01:00:00:00:01/00:00:00:00:00/a0 tag 1 dma 16640 in

Inquiry 12 01 00 00 ff 00res 00/00:00:00:00:00/00:00:00:00:00/00 Emask 0x3 (HSM violation)

Jun 30 14:48:32 mac.localdomain kernel: EDAC sbridge: ECC is disabled. Aborting

Jun 30 14:48:32 mac.localdomain kernel: EDAC sbridge: Couldn't find mci handler

I have run fsck on the hard disk after booting a live image. No errors were found. I do not have enough points to attach the output from journalctl -xb and dmesg.

What do i need to do to find the cause of the problem?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-09-12 00:38:00 -0500

It seems that Fedora 22 is way too finicky for mounting drives. Everything worked fine with Fedora 21 and previous versions, but ever since upgrading to 22, and even doing a fresh install, formatting my drive, Almost every attempt to boot Fedora goes into this emergency mode.

edit flag offensive delete link more

Comments

Your drive is probably failing, you should look into replacing it.

randomuser gravatar imagerandomuser ( 2015-09-12 01:26:41 -0500 )edit
0

answered 2015-07-26 17:29:55 -0500

goodyca gravatar image

By removing an entry in the fstab file that was added for usb access with VirtualBox, I am now able to boot Fedora 22. I have always added the offending entry in previous version of Fedora without any problems. The offending entry:

none /proc/bus/usb usbfs devgid=501,devmode=664 0 0

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-06-30 17:54:07 -0500

Seen: 975 times

Last updated: Jun 30 '15