Ask Your Question
1

How do I not boot to the CLI after uninstalling libinput?

asked 2015-06-28 23:15:49 -0600

idcmaster gravatar image

updated 2015-06-30 22:51:54 -0600

My question is: How do I not boot to the CLI after uninstalling libinput?

So, I have answered my own question and I thought it might benefit everyone else because it took me awhile (and I'm unfamiliar with systemd). So in trying to get CSGO to work properly with the mouse I uninstalled libinput and all the associate packages. Little did I know this uninstalled gnome, so I dropped straight to command line, and was slightly upset with myself. After re-installing gnome I was left with booting to the command line, and wasn't sure how to get back to the 'login' screen. So after reading over forums for awhile and experimenting, here was my solution:

So if you messed things up and are booting straight to command line on Fedora 22, try this from the command line:

  1. ls -la /etc/systemd/system/default.target (This will tell you where default.target is pointed to)
  2. systemctl get-default (To verify what the above ls returned, my result came back as multi-user.target and it should be graphical.target)
  3. systemctl set-default graphical.target

How I arrived at my solution: I checked /etc/inittab and it told me :)

I searched the internet for days on this one!

edit retag flag offensive close merge delete

Comments

Please reformule your question! I do not see a real question... guidelines here

davidva gravatar imagedavidva ( 2015-06-28 23:51:45 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2015-06-28 23:16:28 -0600

idcmaster gravatar image

So if you messed things up and are booting straight to command line on Fedora 22, try this from the command line:

ls -la /etc/systemd/system/default.target (This will tell you where default.target is pointed to)
systemctl get-default (To verify what the above ls returned, my result came back as multi-user.target and it should be graphical.target)
systemctl set-default graphical.target

How I arrived at my solution: I checked /etc/inittab and it told me :)

I searched the internet for days on this one!

edit flag offensive delete link more
0

answered 2015-07-15 17:44:41 -0600

whot gravatar image

what you probably wanted to do was uninstall xorg-x11-drv-libinput, not libinput itself. the libinput doc has a little diagram to explain where that fits in. you can have libinput installed without anything using it. http://wayland.freedesktop.org/libinp...

that said, I'd prefer if users file bugs for things not working rather than uninstalling the package :)

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-06-28 23:15:49 -0600

Seen: 228 times

Last updated: Jul 15 '15