Ask Your Question
0

Xorg settings ignored for Trackball Mouse in F22-KDE(Plasma5)/XFCE

asked 2015-06-28 21:29:05 -0600

sudoer gravatar image

updated 2015-06-28 23:47:41 -0600

davidva gravatar image

Hi Everyone,

My system: Fedora 22 XFCE + KDE (base install was XFCE-Spin) + lightDM.

I have a Logitech Marble Mouse that was working with F22/XFCE just fine, with a 10-evdev.conf file in /etc/X11/xorg.conf.d (I used this resource to generate it: https://wiki.archlinux.org/index.php/... ). After installing KDE Desktop (Plasma 5), my xorg settings are being completely ignored for BOTH XFCE and KDE.

This is my 10-evdev.conf file (which I have been using for years without issue with KDE4 on many distributions: http://pastebin.com/rZTYjxbc.

I have tried renaming 10-evdev.conf, applying a blanket configuration to all mice without hotplugging, and fiddling with things one-by-one in /usr/share/X11/xorg.conf.d/ to no avail. All of my other hardware works without issues. I am getting no relevant error messages in Xorg (http://pastebin.com/SqtXDREA) and my mouse with this 10-evdev.conf configuration works without issue for both F20/KDE and Ubuntu.

Could anyone point me in the right direction as to what could be going on? I am suspecting that there is some service that is now running once KDE/plasma5 was installed. I've noticed that in Kubuntu 15.04, my 10-evdev.conf settings are also ignored.

Your responses are much appreciated, my arthritis depends on it! The marble mouse is amazing when the scroll-modifier works.

Additional information: relevant directory listings

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2015-06-28 23:12:48 -0600

sudoer gravatar image

SOLVED!

It turns out that for whatever reason, the xorg configuration for the marble mouse is dependent on libinput instead of evdev and I've worked around the problem by adding a new file 10-libinput.conf to /etc/X11/xorg.conf.d/ with the contents:

Section "InputClass"
    Identifier      "Marble Mouse"
    MatchProduct    "Logitech USB Trackball"
    Driver          "libinput"
    Option          "ScrollMethod" "button"
    Option          "ScrollButton" "3"
EndSection

I figured that this was required after looking at my xinput properties for the device:

**xinput list-props 8:**

Device 'Logitech USB Trackball':
Device Enabled (151):   1
Coordinate Transformation Matrix (153): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000,   0.000000, 1.000000
libinput Accel Speed (283): 0.000000
libinput Accel Speed Default (284): 0.000000
libinput Natural Scrolling Enabled (285):   0
libinput Natural Scrolling Enabled Default (286):   0
libinput Send Events Modes Available (268): 1, 0
libinput Send Events Mode Enabled (269):    0, 0
libinput Send Events Mode Enabled Default (270):    0, 0
libinput Left Handed Enabled (287): 0
libinput Left Handed Enabled Default (288): 0
libinput Scroll Methods Available (289):    0, 0, 1
libinput Scroll Method Enabled (290):   0, 0, 1
libinput Scroll Method Enabled Default (291):   0, 0, 1
libinput Button Scrolling Button (292): 3
libinput Button Scrolling Button Default (293): 274
libinput Middle Emulation Enabled (294):    0
libinput Middle Emulation Enabled Default (295):    0
Device Node (271):  "/dev/input/event5"
Device Product ID (272):    1133, 50184

This must have switched over after installing KDE/Plasma 5

edit flag offensive delete link more

Comments

we switched to libinput/xorg-x11-drv-libinput as default driver in F22. evdev is still installed but unless you have custom configuration snippets all devices are handled by libinput now. The properties and options are slightly different though, which is why the configuration changes are required.

whot gravatar imagewhot ( 2015-07-15 17:27:15 -0600 )edit

Question Tools

Stats

Asked: 2015-06-28 21:29:05 -0600

Seen: 778 times

Last updated: Jun 28 '15