Ask Your Question
1

How to deactivate bluetooth on startup?

asked 2015-06-22 11:40:35 -0600

florian gravatar image

Hi, how can I disable bluetooth during startup? After reboot my bluetooth is always automatically activated and I have to turn it off manually.

(Machine is Thinkpad X201)

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
3

answered 2015-06-22 11:54:13 -0600

Period 22 gravatar image

updated 2015-06-23 09:28:10 -0600

You can use TLP for that. It's an power management tool and is very useful in any case for extending battery life on laptops. See here: http://linrunner.de/en/tlp/docs/tlp-l...

It is in the standard repositories, so sudo yum install tlp tlp-rdw or sudo dnf install tlp tlp-rdw installs it.

It does not have a graphical interface. You'd have to configure it via the configuration file sudo gedit /etc/default/tlp. The section you want is towards the bottom ("DEVICES_TO_DISABLE_ON_STARTUP").

edit flag offensive delete link more

Comments

1

Thanks. I have tlp installed since a long time but never played with the settings in the conf file.

RESTORE_DEVICE_STATE_ON_STARTUP is also quite nice. Everything remains in the state the devices were on shutdown.

florian gravatar imageflorian ( 2015-06-22 12:46:46 -0600 )edit

Does anyone know what method tlp uses to shutoff devices?

florian gravatar imageflorian ( 2015-06-23 20:37:18 -0600 )edit
1

This solution actually turned out not be ideal. Why? Because bluetooth service is completely disabled and I cannot reactivate it using the NetworkManager from the upper right panel. What I am actually looking for is a solution that does the same as if I go there to the Bluetooth menu entry and shut it off. Any thoughts?

florian gravatar imageflorian ( 2015-06-24 08:54:55 -0600 )edit
1

answered 2016-08-04 01:59:18 -0600

jotak gravatar image

An option is to use the Blueman applet, I don't know if it comes by default in gnome but I use XFCE and it's there by default.

To make bluetooth connectivity as an opt-in instead of an opt-out service, open the bluetooth manager through the blueman applet, then navigate to Display > Plugins > PowerManager and click on the Configure button.

Uncheck "auto power-on". And that's it!

On next startup bluetooth will start deactivated, and you can activate it on demand through the blueman applet.

edit flag offensive delete link more

Comments

thanks, it worked.

ceres2009 gravatar imageceres2009 ( 2016-10-26 03:02:17 -0600 )edit
0

answered 2015-06-23 15:33:00 -0600

EllePi gravatar image
    systemctl disable bluetooth.service

(needs root privileges).

Reboot.

edit flag offensive delete link more

Comments

The problem too is that bluetooth is then completely disabled, and I can't activate it from Gnome's NetworkManager panel. Any idea? What command is executed when I turn bluetooth off using the menu entry in the NetworkManager panel?

florian gravatar imageflorian ( 2015-06-24 09:20:45 -0600 )edit

Did you try: systemctl start bluetooth.service

EllePi gravatar imageEllePi ( 2015-06-24 16:33:06 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2015-06-22 11:40:35 -0600

Seen: 7,600 times

Last updated: Jun 23 '15