Ask Your Question
2

Video problems with Flash player on Fedora 22

asked 2015-06-20 07:45:17 -0600

ptselios gravatar image

updated 2015-06-24 21:32:17 -0600

Hello, I have a Lenove X230 laptop with the latest Fedora 22 installed. I have installed the latest Flash player (64 bits as is Firefox) as well as VLC and relevant codecs(?). I did not used any scripts, I just installed some of them manually. Now, my problem is the video with Flash player. When I visit a web page with Flash video, or video streams, I can hear the audio but 8/10 times, I don't see anything on the screen! In the place of the player, I see a black box, at best!

If I zoom in or out on the page, I can see the player controls, but, I cannot watch the video. It just flickers between black and video frames. Like an on-off switch. The strange thing is that I can watch the video, or the stream in Full Screen mode without any issue!

To recap: I can see a Flash Video in Full Screen with no problems, but not in it's native resolution!

Edit: I checked with Konqueror. No problems. So, it's the combination of Firefox and Flash that is not working. Any ideas?

Facts:

  • Hardware: Lenovo X230 (Intel Graphics Card)
  • Flash Player: 11.2.r202 (Latest available from Adobe)
  • DE: KDE5 with NO composition (I tried with composition on/off and various combinations)
  • I tried with enable/disable Hardware Acceleration on the Flash player
  • I have no problems with VLC, youtube, vimeo.

Any ideas?

Update: I did not try http://fedoramagazine.org/solution-gr... . I saw the article and it says it's for old Intel graphics cards. My VGA is the embeded Intel HD4000 series. I updated the system right and it fixed nothing.

Update2: I used a Live openSUSE 13.2 with Firefox 33.0 and 38.0.1 and the same flash player as in my Fedora 22. No problems at all. The only difference, was the kernel (and the VGA drivers obviously). So this sounds like a bug.

edit retag flag offensive close merge delete

Comments

same problem here; I've tried the updated kernel linked above and also turning off hardware acceleration in Firefox. Flash plugin doesn't seem to have an acceleration option in its preferences screen under Linux.

If I have multiple FF tabs open I'll only see (flickering) video on the first tab; subsequent tabs are audio-only. I saw a player's controls disappear on Konqueror on zoom out but the video kept playing.

I had an OK up-to-date Firefox on f21 before updating.

firefox-38.0.5-2.fc22.x86_64 kde-runtime-15.04.2-1.fc22.x86_64 flash-plugin-11.2.202.466-release.x86_64 4.0.5-300.fc22.x86_64

billmcgonigle gravatar imagebillmcgonigle ( 2015-06-21 23:19:51 -0600 )edit

@Endie: No, I did not tried that. I saw the article and it says it's for old Intel graphics cards. My VGA is the embeded Intel HD4000 series. I am updating the system right now (more than 120 packages) and I will report back.

ptselios gravatar imageptselios ( 2015-06-22 01:10:09 -0600 )edit

Update: I test the same combination with different OS: I used a Live openSUSE 13.2 with Firefox 33.0 and 38.0.1 and the same flash player as in my Fedora 22. No problems at all. The only difference, was the kernel (and the VGA drivers obviously). So this sounds like a bug.

ptselios gravatar imageptselios ( 2015-06-22 11:28:34 -0600 )edit

Try install freshplayerplugin

davidva gravatar imagedavidva ( 2015-06-24 23:48:56 -0600 )edit

I did installed pepper. Instead of flashing I have a black area. So, no, it's not a problem of flash... I believe it's a problem with the VGA drivers.

ptselios gravatar imageptselios ( 2015-07-01 05:24:03 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2015-06-22 08:06:16 -0600

The problem probably is flash-plugin itself, since it's no longer updated for linux. I personally use Google Chrome if I need to use flash. They package in the latest flash player with their browser.

edit flag offensive delete link more

Comments

This is not the case, obviously. If that was a Flash problem it should not work with Konqueror. See my comment.

ptselios gravatar imageptselios ( 2015-06-22 11:27:06 -0600 )edit

Just tested youtube and vimeo using F22 KDE Konq, vimeo and youtube defaults to HTML5 player, not flash player

linuxpjohnston gravatar imagelinuxpjohnston ( 2015-06-24 01:18:44 -0600 )edit

this is not a Youtube-specific problem - flash-only sites are affected. The reporter is not wrong.

billmcgonigle gravatar imagebillmcgonigle ( 2015-07-01 11:07:47 -0600 )edit

Youtube is just fine because of HTML5. Some sites are OK others are not. It's not very consistent. I purely suspect the kernel/Intel driver version because on the same hardware with openSUSE Live KDE I have no problems.

ptselios gravatar imageptselios ( 2015-07-04 01:19:27 -0600 )edit
0

answered 2015-08-17 03:16:10 -0600

enable rpm fusion using dnf and then update fedora in terminal

edit flag offensive delete link more

Comments

why would this help?

wilf gravatar imagewilf ( 2015-11-18 09:15:57 -0600 )edit
0

answered 2015-11-18 04:39:50 -0600

ptselios gravatar image

Just to close it. I finally solved that problem with the installation of the freshplayerplugin, but not immediately. Eventually, it was solved at some point due to some kernel upgrades, I don't remember exactly which version.

The strange thing is that after the freshplayerplugin installation I could see flash only sites using the Tor(!) browser with no problems at all!

edit flag offensive delete link more

Question Tools

3 followers

Stats

Asked: 2015-06-20 07:45:17 -0600

Seen: 3,539 times

Last updated: Nov 18 '15